16

Recently, I have acquired a MacBook Pro Retina. Previously, I had always used Windows, and I still need it, because of Visual Studio. Hence I installed VMware Fusion and Windows 7 as a virtual machine.

The problem is that whenever I launch the VM, VMWare automatically sets the resolution of the guest to the maximum available on the Mac (that is 2880x1800). So I changed the resolution from Windows and set it to 1440x900, but, when I restart, on the login screen, it automatically reverts back to 2880x1800. I thought it was due to the VMware Tools, so I uninstalled them. It now works correctly, however I lose a lot of features without the Tools installed. How can I solve this?

  • I have the same problem but am using the latest version of VMWare, 5.0.2 – ajcw Dec 21 '12 at 18:55
3

Download the VMWare Fusion 2012 technology preview, this issue is fixed in that release.

  • I just purchased a 15" Retina MacBook Pro and had the exact same issue as you did. I'll assume that you are running VMWare 4 and the best solution I found was to upgrade to VMWare Fusion 5. This new version has explicit support for the immense resolution of the Retina screen and it solved all of the resolution related problems I had. – Paul Shaw Nov 19 '12 at 20:54
28

I'm using VMWare Fusion 5.0.3. With vmwaretools installed, it's very easy to change the resolution on the Windows VM:

  • go to Virtual Machine > Settings > Display
  • there is a checkbox Use full resolution for Retina display
  • uncheck it and the vm changes back to normal resolution.
  • Thanks! I created an account here just to give you a +1. That was right on spot! – eestein Jul 30 '15 at 16:54
  • I am using El Captain, Windows 7 pro inside VMware fusion. Now I can set resolution and don't allow it auto-changing. – D Vy Jul 22 '16 at 21:43
5

Edit ~/Library/Preferences/VMware Fusion/preferences file by adding following lines:

pref.autoFitGuestToWindow = "FALSE"
pref.autoFitFullScreen = "stretchGuestToHost"

pref.autoFitGuestToWindow = "FALSE" disables auto fit for Single Window mode. pref.autoFitFullScreen = "stretchGuestToHost" disables auto fit for Full Screen mode.

  • This seems like the best answer. Worked perfectly. (Of course, make sure to restart VMWare Fusion after making these changes). – caleb Dec 26 '14 at 19:40
  • The best answer by far! Others didn't work. I too created an account just to upvote this answer! – Belfield Sep 21 '17 at 11:17
3

You can also use the following command to set the resolution:

C:\Program Files\VMware Tools\VMwareResolutionSet.exe"  0 1 , 0 0 1920 1440
  • Turn on Retina option go the VM, set the resolution you like delete this resolution set exe file mentioned above this will stop reverting back – Bishoy Hanna May 31 '16 at 3:25
1

I dont have a real fix I guess that will require a patch from VMware. In the meantime I found this hint via Google:

Go out of full screen mode (ctrl-cmd-F) and then back again.

1

I am using VMWare Fusion 5.x on MAcBook Retina 13' and as a workaround, I have created a .bat file (auto executable) to automate the commands as suggested by Michiel on my Windows and I just double-click it to bring back my preferred resolution.

ResetResultion.bat file has the following content:

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe"  0 1 , 0 0 1920 1200

You must log in to answer this question.

protected by Community Jan 11 '15 at 21:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .