I just batch edited some pictures with Preview and changed the name of one file in the Preview window. Minutes later, Finder still didn't show the changed file sizes (not even when opening the Info dialog) and changed names. Switching from list view to icon view or so didn't fix it.
I restarted Finder and then the names changed.

How come, is there an update or refresh command? Thought it'd be in the View menu but it isn't.

  • 3
    There isn't an update command because users shouldn't be worrying about that kind of thing, it should "just work". And until recently this has been the case, though it seems like in ML there are some issues with this automagic updating.
    – kLy
    Commented Aug 9, 2012 at 9:04
  • 1
    TMK, finder refresh failures have been around since 10.6. I got one personal report. I experienced it myself in 10.7 a couple times, and now this in 10.8. Seems like they just solved some bugs in AddressBook from 10.5, so maybe 10.9 will solve this? But usually a finder relaunch (force-quit menu) and/or using the <Back/Forward> buttons in the finder window works. Commented Apr 23, 2013 at 17:37
  • 3
    The best answer, as far as my experience has been, is "Poorly, if at all". There are workaround hacks, but they tend to be equally touchy. Apple need to get over themselves, and just admit that a "refresh" button is occasionally needed, even if it's not supposed to be required.
    – Fake Name
    Commented Aug 7, 2013 at 9:23
  • 1
    Network files with multiple people editing them simultaneously is a particularly common situation that pretty much requires the ability to force a refresh of the current directory.
    – Fake Name
    Commented Aug 7, 2013 at 9:24
  • I think that the best answer so far is by @Joris Vanhecke. Please consider accepting it.
    – 0 _
    Commented Jul 29, 2014 at 2:02

4 Answers 4


The Finder's information should be refreshing automatically and instantly as files and information is changing that is the goal and why Apple does not provide a "Refresh" option, although in practice things sometime don't work for whatever reason.

If the information is not automatically updating changes to files etc, it may be the result of a bug or Finder preferences corruption, or other corruption.

  1. Make sure you are running the latest version of OS X, as the issue may be a bug that has been fixed already.

  2. Additionally for folders where the contents are not updating properly it might be a good idea to try and remove the .DS_Store file for that directory, and see if that has an effect. (restarting the finder to verify)

  3. The next option would be to reset the Finder's preferences. Try removing the the file named com.apple.finder.plist located at ~/Library/Preferences/com.apple.finder.plist (restarting the finder to verify)

  4. If the problem is consistently occurring contact Apple and show them the issue and how to repeat it, you may have found a bug.

  • 1
    Nr.3 rm ~/Library/Preferences/com.apple.finder.plist ; killall Finder was definitely the solution! After that my desktop icon sizes&grid&positions were broken, but with some pref tweaking + cp /Volumes/TimeMachine/Backups.backupdb/MacName/Latest/LocalDisk/Users/Name/Desktop/.DS_Store ~/Desktop/; killall Finder successfully restored. Then wrote test script! cd /path/to/refresh-dir/;mkfile 1000000 1mb;mkfile 0 growing;i=1;while [ $i -lt 1024 ];do cat 1mb >> growing; echo "$i mB";(( i++ ));sleep 1;done Finder now refreshes properly! ~Every 2-3 seconds. Prior only on leaving&reentering dir!
    – porg
    Commented Oct 8, 2013 at 21:12
  • Mac OS X Finder's refreshing behavior differs a bit depending the the occurring changes: Single file growing at kB/sec rates (instant), many new small files (1-3 secs), fast growing files (mB/sec) refresh a bit slower (max 3-4 secs). Full Finder Refresh Test Suite which for provoking different refresh behaviors in next post.
    – porg
    Commented Oct 8, 2013 at 21:20
  • 3
    Adding small files frequently: cd ~/Desktop/update/;i=1;while [ $i -lt 1000 ];do mkfile 0 $i;(( i++ ));echo "File Nr $i";sleep 1;done Slowly growing file: cd ~/Desktop/update/;mkfile 1000 1kb;mkfile 0 growing;i=1;while [ $i -lt 1024 ];do cat 1kb >> growing; echo "$i kB";(( i++ ));sleep 1;done Fast growing file: cd ~/Desktop/update/;mkfile 1000000 1mb;mkfile 0 growing;i=1;while [ $i -lt 1024 ];do cat 1mb >> growing; echo "$i mB";(( i++ ));sleep 1;done
    – porg
    Commented Oct 8, 2013 at 21:21
  • Btw, I am on 10.6.8. Sadly, the refreshing bug still occurs. Example of a current manifestation adb backup -apk -all -f ~/Backups/android.ab. android.ab constantly shows the same file-size although its constantly being written to. If I point my fast growing file script at this directory, both the file growing and the file android.ab regularly refresh their file size! It seems that some write operations trigger a refresh, while others don't. I don't know specifics. Maybe certain Services that I use cause that.
    – porg
    Commented Oct 13, 2013 at 14:47
  • Same effect in ~/Downloads. While downloading a file from Chrome, its size is not updated, although its written to constantly. A refresh is triggered, either by navigating our and back in again, or by creating a new or renaming an existing folder within ~/Downloads. When the download finished the size and timestamp are updated correctly. But not while the download progress.
    – porg
    Commented Oct 13, 2013 at 14:57

Alt click and select "Get info." This will refresh the folder. I have this problem with ftp folders mounted as a drive via Transmit.

  • Unfortunately this will not refresh the contents of the files mounted via Transmit. They will still be cached and I haven't found out how to refresh them. Commented May 13, 2013 at 18:24
  • 1
    This worked perfectly in my case for a network share that wasn't showing all of its files. It's worth a try in any case, takes two seconds.
    – user28077
    Commented Jul 15, 2013 at 18:01
  • I've found that this only works sometimes. What seems to work all the time is deleting a file in the folder and then undoing it.
    – nvrtd frst
    Commented Dec 17, 2013 at 23:27

A "Refresh" feature can be added to Finder by 3rd-party software like XtraFinder (free).

  • 3
    You can add it yourself: apple.stackexchange.com/questions/49543/…
    – Barranka
    Commented Nov 14, 2013 at 21:11
  • 1
    Adding it independently of XtraFinder indeed is the "canonical" answer that answers the original question in principle. Nonetheless, for people who haven't tried XtraFinder, please do so: it has many more (and arguably vastly more useful) features besides a refresh button.
    – 0 _
    Commented Jul 29, 2014 at 2:03
  • This solution solved a long-standing problem I had with sshfs with OS X FUSE. For example running scripts on a server that generate image files (PDF, PNG, or other) used to not trigger any update in my Finder. This behavior is very irritating when you are developing code with file access to the locally mounted directory and running it remotely via ssh.
    – 0 _
    Commented Jul 29, 2014 at 2:08
  • This doesn't fix all problems though. I'm looking at an NFS share in XtraFinder, where on the server I changed the name of one of the folders. The old name still remains in Finder. Terminal shows the new name. Refresh does not help. Getting XtraFinder to restart Finder for me, I get a directory listing with the correct name. A second after I click that folder, Finder changes the name back to the wrong one AS I'M WATCHING. FFS, I hate this f***ing Finder. Always been absolutely useless with network shares since my first OS X, Lion. NEVER EVER WORKED PROPERLY! Commented Nov 3, 2014 at 12:56

Just go to the parental directory and into the specific folder again and it refreshes the content. Or use the back and forward button.

  • This doesn't work.
    – swt83
    Commented Oct 22, 2014 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .