My MacBook Air late 2010 worked perfectly before the Mountain Lion upgrade. After I updated to Mountain Lion, the Internet stopped working on my WiFi network. It detects the network and connects to it with no problems, but cannot access the Internet. On my home network, my Windows 7 PC, iPhone, and iPad all connected to the Internet with no issues. I took the MacBook Air to a local reseller and they connected to their WiFi network and it works perfectly fine. I also connected to other public networks and it works fine as well. I also brought it to work and it works perfectly too. Just no internet on my home network. I tried disabling the firewall, but that didn't help.

closed as not a real question by bmike Apr 30 '13 at 14:42

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Did you run the Network Assistant (in Preferences-Network) already? – nohillside Aug 9 '12 at 7:28
  • Did you try the usual (ping your router, ping an IP, ping a URL)? – houbysoft Aug 15 '12 at 22:14
  • This sounds like an issue with your router settings (not the macbook settings as the machine works with other networks). Possibly, for example, it only allows known devices to connect and doesn't recognise your macbook since the upgrade. Maybe let us know what kind of router you have etc. – JamiePatt Aug 15 '12 at 22:22
  • I second @patrix suggestion. The number of times I've been able to get my MacBook Pro to connect to the net by running Network Diagnostics is ridiculous. It doesn't appear to change any settings, but it seems to refresh a few things and magically connects. If that doesn't work, InfluenceJamie's idea is probably your next best bet. You could try resetting your router to make sure that it's not remembering settings from before the upgrade. (Make sure to write down all the info you need to set it up before you restore it to factory settings...) – daviewales Dec 3 '12 at 8:13
  • I'll close this since it may need more troubleshooting and no one's been able to guess what your next step might be. Feel free to flag this for review or just edit in more details if the issue persists. That alone would be good information on where the problem lies. – bmike Apr 30 '13 at 14:42

Browse other questions tagged .