I just bought Mountain Lion in the App Store and it shows the download link. But after I click it and correctly enter my password it does not continue to download. Nothing happens. It just remains on the "download" button. I have installed every update imaginable, including Java and the latest Lion compatibilities, iTunes, everything from the App Store. I checked if my Macbook (2010) is compatible and it is, including the space on the harddrive, 64 bit etcetera. What could it be? Why is isn't it downloading?

1 Answer 1


Try one of the following solutions:

  • Quit the App Store and reboot your Mac. Most of the times, your problem will be solved.
  • Try again in 15 or 30 minutes. Sometimes, as large as the server farms might be, they simply can't handle the overload in request. Maybe later, there will be an open slot for you
  • Flush the cache of the App Store. Opeq Finder and use the "Go to" option to go to ~/Library/Caches/com.apple.appstore. Remove the file and make sure you've emptied your trash.

I hope one of these things will help you out.

  • Thanks! I tried the 1st one a couple of times without help, so I definitely hope it's the server farms. I currently did Repair HD and am backing everything up. After that's finished I'll try your third option and hopefully that will work. Thanks for the quick answer anyway! Commented Aug 8, 2012 at 15:05
  • By trying the 3th option, you won't do any harm. So I would suggest you do the 3th option before you mess around with repairing HDs :-)
    – Michiel
    Commented Aug 8, 2012 at 15:07
  • OH, too late. But it worked anyhow! Repaired the HD and back-uped my Mac. Rebooted and clicked again. It's downloading right now. Without the 3rd option, though. So for anyone else with a problem, try repairing and/or back-up FIRST. Thank you, Michiel for your help!! Commented Aug 8, 2012 at 16:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .