0

I have set up a simple Print Plugin in Automator. It renames the file, then moves the file to a particular directory. No matter how simple I make the plugin, it only triggers every other time I run it.

In other words, I go into Print > PDF > then select the automator script from the dropdown box.

The first time, it appears to "print" but nothing happens; the second time, it runs as expected.

I've looked through my logs, and it appears I get an unrelated error log about Automator Runner on the second time I run the plugin -- it is as though the Automator script isn't getting run in the first instance.

I'm using Mountain Lion.

Any thoughts or suggestions? I'm not even sure where to look next.

1

Jacob Walker writes:

Just saw your note on the Apple Support webpage. I was able to get past the apparent bug by saving the Automator Script as an Automator "Application" rather than a Print Plugin. I saved it to ~/Library/PDF Services and it shows up and works as expected.

This also worked for me.

  • Can you add a link to the post you referenced? Thanks! – daviesgeek Aug 23 '12 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .