Steps to reproduce:

  1. Be doing anything
  2. Close the lid of the computer
  3. Wait around for a while
  4. Open the lid of the computer
  5. Login prompt for last logged in user appears, battery and time MAY update, but trackpad and keyboard are locked up and no response. Computer requires forced-restart.

EDIT: 5a. Possibly, everything is normal, and no lockup/freeze happens.


When the problem occurs, there is no spinning wait thingy or blinking cursor. On the contrary, a spinning wait cursor usually indicates that if I wait for it, the machine will wake up normally, blink the cursor, and let me log in.

EDIT 2a: Software running may vary. No indication of wifi connectivity since the icon may or may not be on, but I may or may not have been connected to wifi at sleep, and may or may not have wifi access at wake--there's no way to tell if the image is actually reporting the state since the image may just be frozen.

EDIT 2b: As best I can tell, the longer I wait to re-activate the machine, the more likely the lockup.

10.8 on Pro Retina (MacBookPro10,1 with NVIDIA GeForce GT 650M and Intel HD Graphics 4000).

Any ideas on how to diagnose or fix?

  • These types of problem are best fixed with physical access to the machine, otherwise it will take a long list of steps to even diagnose the problem. Your best bet will be to take the machine to AppleCare. – duci9y Aug 7 '12 at 14:00
  • 1
    May be a third-party software problem… have you tried booting in Safe Mode? – myhd Aug 7 '12 at 14:54
  • I suppose I could try that; kind-of a difficult test to perform since there's no guarantee that the behavior will actually occur. Come to think of it, I should state that in the question. – Philip Aug 7 '12 at 21:11
  • @GrahamPerrin I should have said trackpad and built-in keyboard. – Philip Aug 10 '12 at 13:06
  • Please, in the question, can you refine – or expand upon – your points 5 and 5a? When the problem occurs, is there a spinning wait cursor? Does a cursor blink in the password field? – and so on. – Graham Perrin Aug 15 '12 at 5:12

I'm going to take a wild stab in the dark guess and say that this is related to the highly documented "Mountain Lion wake bug" (at least that's what I've dubbed it.)

It's been discussed in a variety of threads on apple support forums, but probably the most successful I found was this one. I had the problem too and I found that there was one simple fix on this thread.

Basically, the theory (and I'm 99% certain it's correct) is that the bug relates to bonjour, and some apps that use bonjour in mountain lion are causing wifi processes to hang and thus crashing OSX. Anyway, the program that was doing it for me, and probably what I've seen to be the most common one, is Transmit, the awesome little FTP client by Panic. Unfortunately, Panics Menu Bar icon which can be quite useful appeared to be the worst culprit, but toggling off "Show Transmit Disk in menu bar" in transmit preferences solved the problem.

If you're not using Transmit or if you're still having issue, run through that forum and hopefully you'll find one of the other fixes works for you.

PS. Apple knows about the problem and I think they're working on a fix.

  • Interesting. I'm not using Transmit, but I'll check out your link. – Philip Aug 15 '12 at 13:02
  • It's quite a long thread so you may want to give yourself a half hour or so and start at the beginning. If I had to guess though, I'd suggest you have some other app that uses bonjour and is causing the wifi process to hang thus crashing the system. – JamiePatt Aug 15 '12 at 13:05
  • That certainly seems plausible. – Philip Aug 15 '12 at 13:06
  • I haven't had the behavior repeat for several days, knock on wood. I'm going to accept this as the most plausible explanation, unless/until someone suggests a better one. – Philip Aug 18 '12 at 22:27
  • Was there any particular action you followed from the thread? Or applications that you are no longer using? – JamiePatt Aug 18 '12 at 23:32

Does this happen all the time or only after waiting for a while? What I mean is, does the machine sleep for more than ~10 minutes or so?

If the answer is yes, try this in Terminal.app:

sudo pmset -a standby 0

This disables standby mode, which you can read more about in HT4392. This might also disable Power Nap.

  • Probably "only after waiting for a while" though I haven't kept an accurate record. Can you suggest a solution that doesn't involve disabling useful features? – Philip Aug 10 '12 at 13:08
  • this didn't help. Transmit seemed to be my biggest issue. – Paul Solt Oct 5 '12 at 18:50

Diagnosing an issue that affects WindowServer

Step 5 in the current edition of the question is unclear. With the little that is known, I assume an issue affecting WindowServer.

Suspect an issue affecting the WindowServer process (long edition)

Suspect an issue affecting the WindowServer process (brief edition for power users)

If not WindowServer

The issue may be not directly related to wake, not related to power …

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .