I've updated to Oracle's 1.7 64-bit beta, and this is what my Java Preferences window looks like (you will note that the webapp checkbox is checked and I've restarted my machine since checking it):

Java preferences

I've tried unchecking SE 6 32-bit, 64-bit, and both, as well as disabling SE 7. Doesn't do anything. I've rebooted after installing. No dice. I've checked Software Update. Nope.

java -version reports:

java -version java version "1.7.0_05" Java(TM) SE Runtime Environment

(build 1.7.0_05-b06) Java HotSpot(TM) 64-Bit Server VM (build

23.1-b03, mixed mode)

This test page in Safari returns a blank, Chrome asks for Java plugin, and Firefox says "Java is broken":


which java says /usr/bin/java

Any idea what the problem is? This is endlessly frustrating given how mindlessly simple it is to install Java in both Windows and most Linux builds.

Have tried reverting to SE 6 by uninstalling SE 7. Here's the infuriating reality I am dealing with:

  • As this is re a beta I think it is too localised
    – mmmmmm
    Commented Apr 13, 2013 at 21:04

2 Answers 2


My solution was to purchase and install Mountain Lion. It works now. Really wish I knew what the actual problem was though...

  • 1
    I have Mountain Lion and it works in Safari but not Chrome. I have the same setup as you in Java Preferences. Commented Aug 15, 2012 at 23:28

For chrome: have you tried enabling javascript? it's in the contents setting bit of the preferences. In Safari, in the Preferences -> Security settings, there is a 'enable Java', 'enable JavaScript'. In Firefox Javascript is in Preferences -> Contents.

If JavaScript and Java are enabled then the problem is going to be a different one, but it pays to check.

  • Yes, Java and Javascript are both enabled on all my browsers.
    – Michael B
    Commented Aug 7, 2012 at 15:35
  • 3
    JavaScript has nothing to do with Java at all… Commented Aug 15, 2012 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .