All right. I've played games on my MacBook Pro using a crappy Microsoft Sidewinder gamepad for years, plugged into my USB port. I just upgraded to Mountain Lion a few days ago, though, and for some reason, I can't get any programs to recognize my controller's button presses. System Information (not System Profiler anymore, I guess) will tell me it's plugged in, sure, but no programs will actually register button presses. It's rather odd, and extremely frustrating since I would really like to, you know, use the controller.

I've tried unplugging it and plugging it back in after a few minutes. Or hours. I've tried restarting with the controller not plugged in. I've tried restarting with the controller plugged in. I've tried using a different controller to rule out controller malfunction. I've tried using a different USB port. (I have a USB mouse and it works in either port.) I think signs point to a driver issue, but why would Mountain Lion suddenly be incompatible with my controller if it worked under Lion? Something's very strange here. Thank you very much!

EDIT: The USB Prober app from the Hardware I/O Tools download (from the dev site) sees my controller just fine. It identifies it and everything. Other applications, on the other hand, don't...

EDIT x2: I restarted with the controller in the port, and it was working! Hoorah! I used ControllerMate to see what was up, and it recognized everything I did! I played a game with it and quit the application. But now it no longer works; ControllerMate suggests that some other software is controlling my controller. I've had issues with this with my built-in camera before, years ago, but they kinda just went away. So I'm still stuck -- unless the only way is to restart every time I want to use my controller, which is kinda anti-Mac. Suggestions?

EDIT x3: Well, that's kind of odd. The Ink preference pane showed up for some reason. And weirder, after a restart where my controller was connected during startup, I could use the controller as a mouse. It was actually moving around the pointer, though only in an absolute sense: when I let go off the direction pad, the cursor jumped to the center. I disconnected the controller and plugged it back in, and now it doesn't work again.

EDIT x4: The Ink prefpane was due to SteerMouse; I uninstalled it and the prefpane went away. I also reset my NVRAM, but no change. However, I figured out something very important. I had the controller running, then I used Chrome for a while. Controller was still running. I used Chrome again. Controller stopped. Gah, not again. I quit Chrome. Controller came back online immediately.


Perhaps the reason I thought it was my Mountain Lion update is because Chrome did an auto-update at the same time, or perhaps Mountain Lion breaks Chrome's behavior, or perhaps Mountain Lion's USB drivers don't like Chrome. Whatever the situation is, I've at least managed to pinpoint the problem better. Still not solved, though...

  • I've got exactly that, with Snow Leopard. I close chrome and my controllers start working again. When was the last Chrome update?
    – user27432
    Aug 14, 2012 at 23:48
  • Never in a million years would I have thought of this, but this worked for me! Sep 16, 2012 at 18:51

3 Answers 3


I was having virtually the same problem and it turns out Chrome was the cause.

I'm using an Xbox 360 controller on Mountain Lion with the tattiebogle driver. Recently, my controller would just cease to respond, even though it was showing as connected and no amount of disconnecting/re-connecting would fix the problem; the only thing that seemed to work was a re-boot.

I was doing some research earlier and came across this post. I found it hard to believe that Chrome would be the cause, but sure enough, the controller has stopped working twice now and both times I closed down Chrome, re-connected, and all is fine again! Thanks for your post, it helped me a lot!


Install Chrome's latest beta http://www.chromium.org/getting-involved/dev-channel

Same was ocurring to me, with osx 10.7.4 and Chrome 21, installing 22.0.1229.56 beta solved the problem.

ps: Thanks for this post, saved my week!

  • You say "beta", but link to dev. Those are two very different things. Sep 18, 2012 at 14:37

Try to see if a third party USB controller will work. Something like SteerMouse. Even though is says Mouse in the name, I believe that it does other USB devices as well. I think that there is a trial, available so you can try before you buy. There are other USB mouse controllers available for Macintosh if this doesn't work.

  • That one really doesn't work... Any idea how to find out which process is holding my controller hostage? Aug 6, 2012 at 22:34
  • Hm, actually, it's weirder than that. SteerMouse makes my computer think my controller is a writing tablet, but the problem with recognizing button presses is still there... Aug 7, 2012 at 11:19
  • I finally remembered the name of the other USB controller that I have used. It is USB Overdrive usboverdrive.com . From their web site: "The USB Overdrive is a device driver for Mac OS X that handles any USB mouse / trackball / joystick / gamepad / media keyboard and any Bluetooth mouse from any manufacturer and lets you configure them either globally or on a per-application, per-device basis."
    – Ɱark Ƭ
    Aug 7, 2012 at 11:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .