I have my iMac set up with:

  • Firewall off
  • Screen sharing on for specific user, no general VNC password
  • File sharing on (with liberal access)

I want to connect to it's screen from my MBPro. Whenever I try to start a screen sharing session from the MBPro to the iMac, either via Finder's screen sharing dialog or by calling the Screen Sharing app directly, it just hangs. And hangs. And hangs. And eventually the "Connecting..." window just quietly disappears and no screen is shared.

I checked Keychain to make sure there isn't a bad password set for the iMac and, nope, nothing there. I'm not being prompted for a user name or password from Screen Sharing when it runs.

I don't have a central user authority on my network. Each Mac has its own local user settings. But the user names and passwords are identical.

I can connect successfully using Jolly's Fast VNC. It actually finds the iMac via Bounjour broadcast. But this software, technically, is not free and I'm perplexed as to why the built-in Mac approach isn't working for me.

Update: here are the screen sharing settings on the iMac.

Screen Sharing Settings 1

And this is what I have set when you click on the 'Computer Settings...' button:

Screen Sharing Settings 2

Jolly's Fast VNC continues to find (via Bonjour) and connect to this machine without any issues. I have to give it my user name and password for the iMac when I want to connect. Finder, on the MBPro, can connect to the file shares (using my iMac user name and password) just fine. Clicking 'Share Screen' in the Finder window wakes up the iMac -- the display turns on and what not. But the connect times out.

Are there log files for Screen Sharing on the MBPro I can look at to debug this? What about log files on the iMac for Screen Sharing? Something that might shed some light on why Screen Sharing says it's connecting and then just mysteriously stops?

  • When you mean it hangs, it just act like it wants to connect and never does? Can you click the machine in Finder (on the sidebar), and click screen sharing? Is the remote machine awake?
    – jmlumpkin
    Jan 5, 2011 at 18:31
  • Says it's connecting and eventually the little dialog window goes away, Screen Sharing program is running, but no shared screen is visible. The machine is awake, browse-able via Finder. I can use it's shared drives.
    – Ian C.
    Jan 5, 2011 at 18:39
  • Does trashing the plist for screen sharing fix it?
    – ridogi
    Jan 19, 2011 at 7:03
  • @ridogi -- finally able to try nuking the plist and...I can't find one that relates to screen sharing in ~/Library. Any idea what I might be looking for here? Thanks.
    – Ian C.
    Jan 24, 2011 at 17:46
  • ~Library/Preferences/com.apple.ScreenSharing.plist
    – ridogi
    Jan 25, 2011 at 4:26

2 Answers 2


Since the Screen Sharing feature seems to be the only one unable to connect, the best way to diagnose its behavior is by using the application directly.

Please, launch screen sharing located in:


The application has no visible "UI" so don't expect a fancy Cocoa interface. Instead, once you have loaded it, all you'll see is this "poor" icon in the Dock:


Click on it and then go to Preferences in the Mac menu bar. You should be presented with:

sshar preferences

Notice the second option to only encrypt passwords and keystrokes. That's fine, but as you can see, there's no option to skip encryption altogether. Some VNC versions have incompatibilities with encryption, but this would be rather shocking since you're talking about OS X vs OS X.

In any case, once you have the settings like that, try connecting, again, in the menu bar: Connection -> New (or ⌘cmd + N).

A simple dialog appears asking you to enter the Host's name. Following your screenshots, try: and hit enter.

We'll see what happens from here. Also, have the Console.app open on both computers, to see if there are any System messages going on (or anything related).

  • This worked. I think the key to success here was using the IP address of the machine. I'd only tried this approach using the hostname, which doesn't seem to be resolving. I guess the Finder approach is using the hostname. Nice catch. Enjoy the points!
    – Ian C.
    Jan 26, 2011 at 4:45
  • @Ian glad to see if it worked. I find it odd that Finder (using Bonjour) is not finding the other host properly. If you want to do some more investigation, try changing the host name, that would flush it and will broadcast it again through mDNS (bonjour discovery service). Maybe finder will catch it this time. ;) Jan 26, 2011 at 12:20
  • bounty awarded. So for the delay man. I thought accepting your answer gave you the bounty.
    – Ian C.
    Jan 31, 2011 at 17:23
  • @Ian no worries, thanks. i really don't mind rep that much :) I would have liked the other contributors to add info and win this, we need more people :) Thanks anyway. Glad you fixed it. Jan 31, 2011 at 19:48
  • Firing the app up directly and entering the IP address (as opposed to doing Share Screen via Finder) worked for me too. Thanks! Sep 4, 2013 at 9:26

since your a site to site mac network, your networks dns servers need to be update with A records of your mac machine names, to whatever.whaterver.com or .edu or what ever you are,

that way the dns can resolve host names to ip addresses, it is especially complex on spaced names, windows machines with simple names are easy to convert, name to ip either via WINS or DNS, so you have 2 choices for the future,

  1. create local name mappings to STATIC ip addresses on the macs into your /etc/hosts file on EACH mac

  2. buy your it folks some donuts and coffee and kindly ask them to setup some a records in DNS for your macs.

  3. if you have an Xserve it should do this for you, just make sure your directory utility is setup to use it.

  • Coming from time frame 4 years in the future: your analysis sounds correct, the problem is a DNS of IP managment one.
    – dan
    Oct 4, 2015 at 12:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .