I have a problem with Wine and Steam on my Mac. I recently updated to 10.8. When I had Lion Wine and Steam worked perfectly, but because of some problems I had to re-install Wine. The thing is, now that Wine is re-installed, I can't install Steam. First off, when I run the installer the console shows:

fixme:storage:create_storagefile Storage share mode not implemented.

Then, after I start the installation and press the first next, the X11 window disappears and never re-opens (believe me, I left it for half an hour and nothing happens, not that it should take more than a few seconds, but still). X11 is still running, or rather XQuartz. What is wrong and what does fixme:storage:create_storagefile Storage share mode not implemented. mean?

  • 1
    Did you update Xcode and XQuartz to the appropriate Mountain Lion versions? These updates are not included with 10.8 and may need to be performed by hand for Wine to run properly. Xcode should be 4.4 and XQuartz should be 2.7.2.
    – harpermd
    Aug 5, 2012 at 7:16
  • Yes. If I try any other installer, it works
    – rdelfin
    Aug 5, 2012 at 14:01

1 Answer 1


How did you install Wine? When I installed Wine using Homebrew, it told me that it had problems with the new Apple llvm compiler, and said to use the old GCC compiler, and gave me a link to download and install it. I haven't tried to install Steam in Wine though, so I don't have experience with your specific problem.

  • Thanks but I esentialy fixed by using wineskin instead and it works well
    – rdelfin
    Aug 24, 2012 at 3:05
  • I had the same issue as the person who asked the question; installing the latest stable GCC and recompiling Wine using GCC fixed the issue for me. Aug 17, 2013 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .