A brand new Magic Trackpad has been paired to a 2011 Mac mini with OSX 10.8. This mini has no other bluetooth devices. OSX was upgraded in-place from Lion to Mountain Lion.

The trackpad doesn't perform the gestures.

The Bluetooth menu shows that there's a mysterious bluetooth mouse device still as of yet unconnected. Various attempts to have it connect are unsuccessful. I suspect this is the gestures functionality, but it may be a previously connected mouse (unsure).

Various fixes attempted:

  • reset PRAM with Cmd-Option-P-R at boot.
  • reset SMC by pressing power when unplugged

How can I get this Magic Trackpad to be recognized by OSX Mountain Lion? I don't have another Mac to try to reproduce this problem on (trying to determine if the trackpad itself is bad).

enter image description here

enter image description here

3 Answers 3


Your trackpad preference page is an earlier version than 10.8. I think 10.7 or before, so this is likely a software issue** The 10.8 page has changed a lot compared to your screenshot.

enter image description here

In the lower left it should say trackpad battery level and have battery icon with percentage. Having had some bluetooth problems in the past it should give you a battery level even if it is zero, unless the device is not completely paired, possible hardware issue.

With 10.8 under the Bluetooth preference page it will give you a list of all Bluetooth devices that have been paired with your machine, at the bottom below the devices should be a + - and a sprocket with a drop down menu that includes connect, rename, add to favorites, update name, update services, and show more info. The - will delete the selected device, I would suggest you delete the ghost mouse and maybe even the trackpad and try to pair the trackpad again. Also on the bluetooth page I have discoverable not selected.

If you are running 10.8 and you have Apple Care I would contact Apple as your screen shot is showing an earlier version than 10.8 as far as I can tell.

  • Thanks! I've installed ML over top of Lion, so that's an interesting thing you've noted. I wasn't prompted to install any new software when connecting this trackpad. There are no updates in the App Store as well. Thanks for answering!
    – p.campbell
    Commented Aug 5, 2012 at 15:00
  • Thanks Clyde. With the knowledge that my trackpad prefs page was Lion-era, and yet I was running Mountain Lion, I decided to wipe and reinstall OSX. All works well as expected.
    – p.campbell
    Commented Aug 7, 2012 at 15:29
  • @p.campbell you are very welcome, I find it interesting that an older version of the pref page stayed with upgrade especially since they are pushing touch.
    – rclyde
    Commented Aug 7, 2012 at 16:23

It's possible that the kernel extension for the trackpad isn't loading properly.

Try these steps and see what happens.

  1. Open Terminal and type kextstat | grep AppleBluetoothMultitouch and hit enter.
    • If nothing along the lines of 69 0 0x19d2000 0x3000 0x2000 com.apple.driver.AppleBluetoothMultitouch (160.7) <68 64 30 4 3> shows up, then the kext isn't loading.
  2. If you did get text similar to that above, try unloading the driver with the command sudo kextunload /System/Library/Extensions/AppleBluetoothMultitouch.kext. There may be some error messages that spit out, you can ignore them for the moment.
  3. Try reloading it with the command sudo kextload /System/Library/Extensions/AppleBluetoothMultitouch.kext

If after that it doesn't show up in Keyboard Preferences, I'm out of ideas - it may be time for an exchange or a trip to the Genius bar, as it's likely a hardware issue.

It may also be helpful for other's diagnostic purposes to amend your question with the output from the Bluetooth section of System Information (in the /Applications/Utilities folder).

  • Thanks Canuck. I tried your suggesttions. I did NOT see any results from kextstat. I tried the reload, but it didn't seem to change anything. Added the BT screenshot to the question. Thanks!
    – p.campbell
    Commented Aug 4, 2012 at 23:12
  • Okay, a couple more thoughts. After reloading it (step 3), repeat step 1 and see if anything shows up. Secondly, open Console.app and search for anything matching Bluetooth, Mutlitouch, kext or anything else you see that looks like it might be related to the trackpad. Also look at the console immediately after pairing the trackpad, see if anything shows up.
    – robmathers
    Commented Aug 4, 2012 at 23:17

I had an issue like this with a Magic Mouse because I hadn't uninstalled USB Overdrive properly so /System/Library/Extensions/USBOverdrive.kext was still loaded.

USB Overdrive's support page has a list of other kernel extensions related to input devices:

  • KensingtonMouseDriver.kext
  • LCC.kext
  • LogitechHIDDevices.kext
  • LogitechUnifying.kext
  • LogitechUSBHIDevices.kext
  • MacallyKMDriver.kext
  • MicrosoftKeyboard.kext
  • MicrosoftMouse.kext
  • SteerMouse.kext

If you have any of those, try running the uninstallers for the drivers or applications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .