Edit: Case closed! I reinstalled my OS and now it's working.

I've got one Mac Book, one Mac Book Pro and one Mac Mini (the latest version). The Mac Book can easily connect to and browse files and folders using Finder on my Mac Mini via my wifi network but not the Mac Book Pro and I think I've set everything up right - enabling file sharing on the Mac Mini and also screen sharing. Both file sharing and screen sharing works from my Mac Book using the main admin account on my Mac Mini.

When connecting from my Mac Book Pro I'm able to connect through Finder and see the shared folders on my Mac Mini but when double clicking a folder (for example the folder called "Richard") I get this error message:

The operation cannot be completed because the original item for "Richard" cannot be found.

The error message is actually in Swedish, since that's my language, but I'm pretty sure it's translated exactly like this on a default Snow Leopard installation.

Also, a weird thing is that when I first set up my Mac Mini I was actually able to access it and browse files from my Mac Book Pro as well, but just for a week or so and then this error message started showing up. Don't know if I might have changed any settings but I don't think so.

Does anyone have a clue what this problem is due to and how I might be able to solve it? I would love it if I could at least get some hints on how to address the problem - what to look for in the system preferences etc. And please let me know if I'm not giving you enough details!

  • Richard, if that's the solution, please add it as an answer and then accept it.
    – Dori
    Jan 10 '11 at 10:13
  • Not to nitpick, but that was part of my comments on the answer I wrote. Jan 12 '11 at 6:30

The error sounds like it's unable to resolve the alias to the original source. What I would do is remove the shared folder(s) from the Preferences on the Mac Mini, and recreate a preference for a specific folder (ie. Public), with further testing. If the issue were to persist, I'd create another User and test from there.

  • Thanks David, but I've tried both and tried it again now - still the same error message. Is there a way to like reset all preferences in Snow Leopard? Do I need to reinstall then?
    – Richard B
    Jan 5 '11 at 18:33
  • If you have an Apple Store around, it might be worth giving them a hands-on with it. There are a variety of other solutions, from resetting your ACL's to adjusting the network name (ie. Richards-Mac-Mini.local) that might fix it. Reinstalling the OS from the Snow Leopard CD will default to an Archive & Install option, which will attempt to preserve the User data while rebuilding the OS. I'd opt for that before considering a complete erase. Jan 11 '11 at 17:20

You must log in to answer this question.