1

I erased the SSD drive in my MacBook and was reinstalling Lion when it failed about 75% through the install. Now in Disk Utility, sometimes I see the SSD drive and sometimes I boot and it's not there but I can never erase or partition it. I get an "error 6988 couldn't unmount disk".

When I attempt to run fdisk to correct the MBR. fdisk doesn't do anything.

Any ideas how to fix a disk that is this severely screwed?

-bash-3.2# diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *64.0 GB    disk0
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *31.9 GB    disk1
   1:                 Apple_Boot Recovery HD             650.0 MB   disk1s1
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *1.3 GB     disk2
   1:        Apple_partition_map                         30.7 KB    disk2s1
   2:                  Apple_HFS Mac OS X Base System    1.3 GB     disk2s2
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk3
/dev/disk4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk4
/dev/disk5
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk5
/dev/disk6
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk6
/dev/disk7
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk7
/dev/disk8
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *6.3 MB     disk8
/dev/disk9
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *2.1 MB     disk9
/dev/disk10
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *1.0 MB     disk10
/dev/disk11
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk11
/dev/disk12
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *524.3 KB   disk12
/dev/disk13
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               *1.0 MB     disk13
-bash-3.2# diskutil info /dev/disk0
   Device Identifier:        disk0
   Device Node:              /dev/disk0
   Part of Whole:            disk0
   Device / Media Name:      Corsair Performance3 SSD Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      None
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified

   Total Size:               64.0 GB (64023257088 Bytes) (exactly 125045424 512-Byte-Blocks)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                No

   Whole:                    Yes
   Internal:                 Yes
   Solid State:              Yes
   OS 9 Drivers:             No
   Low Level Format:         Not supported

-bash-3.2# fdisk -u /dev/disk0
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory

    -----------------------------------------------------
    ------ ATTENTION - UPDATING MASTER BOOT RECORD ------
    -----------------------------------------------------

Do you wish to write new MBR? [n] y
-bash-3.2# 

migrated from serverfault.com Aug 4 '12 at 14:58

This question came from our site for system and network administrators.

1

I can't test it but I think that if you erase the MBR (with dd instead of fdisk) and the partition table record you should be able to re-format you ssd. Boot from cd or external hd and open terminal

this code erase the MBR:

# dd if=/dev/zero of=/dev/disk0 bs=446 count=1

this one erase the partition table also:

# dd if=/dev/zero of=/dev/disk0 bs=512 count=1

If you erase just the mbr you could use testdisk to attempt to recover data (in case you don't have erased the disk label).

1

I got the same "error 6988 couldn't unmount disk" message. It was due to unclosed references to the drive/partition - particularly I had a terminal window open and the PWD was on that volume. Close that window and close all Finder windows that has reference to that volume (or simply cd to a different directory outside of the mounted disk tree), redo the steps, it should work.

  • 1
    Thanks a lot for your hint. It saved my day! For me a cd / solved this problem. – user168226 Jan 30 '16 at 17:42
  • @Bodo yup. Change path to other directory would work also. :) – Devy Feb 1 '16 at 15:46
0

You have to close all the Finder's instances pointing to the SSD/SD, same for the terminal windows etc. Don't forget to close cloud drive apps such as Dropbox if you are sharing folders that are stored on that SSD/SD drive. In case you have your Photo library on this drive, don't forget to kill the Photo analysis daemons (processes) - this was actually the last thing that prevented my SD to unmout before converting it to APFS. To kill those processes, you can open Activity Monitor app and type "photo" to the searchbox. You will see something like "photolibraryd" and "photoanalysisd". I had to kill these two in order to get the SD drive unlocked for unmounting.

0

I was trying to format my second, data disk in my iMac 5K (128 blade as boot) many times and it failed with the same error.

Finally, I switched to View > Show All Devices and performed the same operation again on my data volume. This time, it worked fine.

Disk Utility

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .