I am trying to upgrade my mid 2009 13" MacBook Pro with a Samsung 830 SSD but I am experiencing a lot of issues.

The issues starts at installation time, when I sometimes get a kernel panic when I try to setup the system with the SSD in pace of the original HDD. If the installation succeeds, the game is not over. I can still reproduce I/O errors running BlackMagic Disk Test Speed. I never tried to go on since I feel that the system is unreliable for day to day usage.

I did both PRAM and SMC reset, but none of them seems to be effective. My Mac and the SSD firmware are updated to the latest versions available.

I also tried to replace the original SATA cable (Which works fine with the original HDD) with another SATA cable coming from another Mac but I get the same error again.

I exclude RAM issues too. I tested with different RAM banks (All of them working perfectly) and the SSD problem is still there.

The very same SSD is working properly on a Windows machine and on another Mac, so I would exclude a disk failure and I guess that there is something wrong with my Mac. The SSD also works perfectly when used in a USB box.

Do you have any suggestion on what should I do next?

  • Which OS X version is running on the Mac in trouble and on the other one (where it seems to work)?
    – nohillside
    Aug 4, 2012 at 13:29
  • In both cases I performed a clean install of OSX Lion and that SSD were the operating systems disk. Last week I installed Mountain Lion on my Mac (on the original hard disk) Aug 4, 2012 at 13:34
  • On my Windows machine I performed a clean install of Windows 7, which worked flawlessly Aug 4, 2012 at 13:39
  • @patrix it does not seem to me an OS error Aug 4, 2012 at 15:27
  • 1
    We are looking for differences between the two Macs. If the OS, the drive and the cable are the same, the problem most probably is the Mac itself. Are these identical models?
    – nohillside
    Aug 4, 2012 at 15:39

2 Answers 2


This is my 2 cents worth. I have no specific experience for Samsung SSDs but I do have a fair amount of experience with Mac Laptops and MacMinis with SSDs.

I am post specifically because I have been fighting with an apparently "similar issue" and have come to the conclusion that SSDs are more tricky than hard drives fro a troubleshooting point of view. I have had to return a few SSDs to the manufacturer ( distributors ). In fact, I returned one to OWC just today that has resisted attempts to update it's firmware - twice over several months and began exhibiting poor performance and I was having kernal crashes that I believe were SSD related. I use a utility called "Trim Enabler" for two reasons: 1) I like to watch metrics that perhaps give insight on storage health - the observable health parameters of the SSD and a second Harddisk on my 2012 MacBook Pro and 2) because it turns on the Trim functionality which SOME SSDs like ( need ) or something....

While OWC ( macsales.com ) is a Mac specialty supplier and appear to be experts and have been good to me over the years, but in this case of SSDs, they have failed to come up with a way that I have access to test my own SSDs or a surefire efficient way to identity if the SSD is the issue or if firmware update will help and thus I returned the SSD today and replaced it with a Crucial SSD which uses different firmware - Sandforce firmware. I have experience with the Crucial SSDs for almost 4 years on Mac's and they seem to work well. It was Crucial who told me to used the 3rd party software called Trim Enabler to "enable trim" after I experienced significant performance issues that Crucial tech support believed was because the SSD was not doing necessary maintenance on itself - i.e. Trim.

Now with all that said, I believe there is still a bit of black magic going on - perhaps it is just marketing and/or marketing secrecy so that SSD makers secret sauce does leak out. Personally, I don't like the effects of the secret sauce on the end user's ability to get genuine information and tech support so they can make informed decision on their purchases of SSD.

Even so, I might recommend you try a OWC or Crucial SSDs based on those companies recommendations and warrenty policies. I no long expect trouble free saling or perfect performance or zero maintenance for a busy SSD. I have never done firmware updates on hard disks but SSDs appear to need these firmware tweeks.

I would love some genuine information at the global statistics level, so that I can better gauge my experience against what the global pool experience is showing.


If your MBP has SATA II (assuming mid-2009 model), does your new SSD support SATA II? I have a similar problem. Having (MacBookPro7,1, mid 2010, 13″) with Samsung SSD 840 Evo 250GB, which supports both SATA II (3Gb/s) and SATA III (6GB/s).

When installed SSD as the main drive had I/O Errors, even failed to boot completely. One SSD died completely, but was replaced. I tried to run SSD with and w/o TRIM, no difference - still I/O errors. With HDD all works fine. I haven't changed the SATA cable yet, but wonder if the whole problem is not just SSD that hardly can run at SATA II mode although it should.

  • My SSD was supposed to support both SATA II and SATA III. I read online of people who installed it in the very same Mac I have so probably they are compatible. Unfortunately there is something wrong with my machine as I have never been able to use the SSD reliably and I finally decided to use it on another PC of mine (With SATA III), on which it works perfectly. I even tried to change SATA cable and to install the disk on a Optibay but the disk still presented I/O errors with both solution attempts. Dec 10, 2013 at 8:07
  • 1
    I will probably also quit and either wait for a firmware update or just simply sell the current Samsung SSD 840 EVO, which claims being compatible with SATA II and SATA III, but in fact is not. Hard to blame either Apple or Samsung, but it is not reliable configuration. Thank you for sharing your experience.
    – JaryMachy
    Dec 10, 2013 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .