I encrypted a Lion partition called "Storage" and it worked perfectly. I needed to decrypt it momentarily because I had some issues, but now I want to encrypt the same volume again and it says "The Core Storage-targetvolume is already encrypted".

Other partitions work fine with decrypting and encrypting, just not this one. Perhaps it has something to do with my home-folder being on the "Storage" partition, but it is strange that encrypting worked the first time and now it doesn't anymore after I decrypted it.

  • Did you by chance just destroy one of the encryption keys rather than actually unencrypt the volume?
    – bmike
    Commented Oct 28, 2012 at 13:42

1 Answer 1


When you say you decrypted it momentarily, it can take from minutes to days depending on the size of the partition and data within it and the speed of your system. The same goes for encrypting. The amount of free space also impacts how long things will take as it needs to encrypt/decrypt files somewhere.

It could be the case that it hasn't finished decrypting it yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .