3

I have a volume mounted. If I switch to another user, this volume gets dismounted. The problem is that I want this volume to be available for every user (but putting it in their login items is not the solution I'm looking for), so: how can this behavior be prevented? (I'm on Mountain Lion)

  • Are you mounting the volume manually after logging in? – Graham Miln Aug 2 '12 at 11:43
  • Yes, that's what I do. – user732274 Aug 2 '12 at 11:53
1

You can stop Mac OS X unmounting user disks on log-out. This behaviour is controlled with a default (preference).

In this discussion on the Apple Support Community, Király shares the appropriate command to issue:

defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin -bool YES

This command needs to be entered into Applications > Utilities > Terminal.app. Aftwards you must restart your Mac for the change to take effect.

Note that the autodiskmount tool has been replaced by automountd; it is possible Mac OS X 10.8 has migrated this default to another file.

You may also find this Super User question useful, Automount external hard drive on Mac.

| improve this answer | |
  • 1
    Just a note that I tested the AutomountDisksWithoutUserLogin flag with 10.9.4 and it still works properly. – Dennis Wurster Jul 30 '14 at 13:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .