Display now

My Mid-2010 Macbook gone wild since morning.

I was running snowleopard but has Lion (dual boot). The recent changes I've done today is, installed trial version of AirParrot app and tried to use Extended display (it seems to install a virtual driver or something)

The delta of changes I've today are

  • Installed Airparrot trial
  • Updated Firefox 13 to 13.0.1
  • Tried newly bought wireless combo (Logitech K260)

Booting into OSX Lion also having the same issue. I've manually deleted AirParrotDriver.kext & APExtFramebuffer.kext from system and rebuilt kext cache

Another odd issue i notified is preview is not loading images, but quick look display the image from finder. (attached image) throws msg "invalid pixel format" & "invalid context" in console.app

I use acer 23" as secondar monitor, The issue is on both the display. As i said in the title, the display is working fine in safeboot.

I'm running safeboot to post this question.


It seems to be issue with hardware issue. I reinstalled Lion on separate partition, it doesn't fix it.

  • Safeboot works on snowleopard and lion
  • Reason being it doesn't load Quartz Extreme (related to graphics card?)

Update 2:

Disabling Quartz in Quartz Debug utility clears the Yellow grids in dragged/selected area of the screen.

Quartz Debug

Update 3:

Attaching the GPU-Z info (windows7 with bootcamp)



Btw, Apple authorized service provider confirmed, GPU is the culprit and cost me Logic board upgrade. To add oil to the fire, they also said battery is dead too (Service status)

  • Are these screenshots or pictures? If it doesn't show up in a screenshot, it's probably a physical (hardware) problem (i.e.: connection cable loose, graphics card unseated, etc.)
    – Matt
    Commented Aug 9, 2012 at 8:10
  • These are screeshots. After disabling the quartz I dragged the mouse to clear the checkered.
    – palaniraja
    Commented Aug 9, 2012 at 9:49

1 Answer 1


Those checkers are usually a Graphics RAM corruption. When you're in Safe Mode, OS X's graphics hardware acceleration is turned off as it is when you turn off Quartz in Quartz Debug.

My opinion is that there is no way to fix it except exchanging the main board.

  • You are right. I've updated the question with gpu-z info as well.
    – palaniraja
    Commented Aug 19, 2012 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .