0

When I look into Console (/Applications...), I see a lot of entries that talk about programs I have uninstalled a long time ago, for instance

01.08.12 10:31:29   com.apple.launchd.peruser.502[206
(de.novamedia.NML2NDeviceObserver[58300])
posix_spawn("/Applications/launch2net/launch2net.app/Contents/
MacOS/NML2NDeviceObserver.app/Contents/MacOS/NML2NDeviceObserver", ...):
No such file or directory

The "launch2Net" was uninstalled some years ago! The same thing for "Carbon Copy Cloner", a program I tested some time ago... how can I avoid the causes for those entries? Is there a cleanup?

2
  • How did you uninstall them? Maybe this program has an uninstaller, and should not just be dragged to the Trash?
    – Gerry
    Aug 1, 2012 at 8:43
  • I cannot remember :-) Maybe I used the uninstaller, maybe not... nevertheless, the entries are there ^^
    – strauberry
    Aug 1, 2012 at 8:47

1 Answer 1

6

It's trying to start the nonexistent apps.

From the console entry com.apple.launchd.peruser.502 we know it's trying to start on behalf of user (instead of system or administrator) that has UID 502.

You can get particular user's account name with id -u -n 502.

I'd look at following places:

Login items

Go to System Preferences->Users & Groups. Choose appropriate user and select Login Items tab.

Look if you recognize uninstalled applications in the list and delete them. You have to select the app and press '-' beneath the list.

Launchd

Start the terminal. Enter launchctl list and see if you find uninstalled apps in there. False entries can be removed by launchctl remove label, for example launchctl remove de.novamedia.NML2NDeviceObserver.

Repeat the process, but this time prepend sudo to commands, like sudo launchctl list, to catch all the apps executed in system context.

You can find out more about launchd and launchctl by entering man launchd and man launchctl.

Launchd configurations

Look into following directories (from man launchctl):

  1. ~/Library/LaunchAgents - Per-user agents provided by the user
  2. ~/Library/LaunchAgents - Per-user agents provided by the administrator
  3. /Library/LaunchDaemons - System wide daemons provided by the administrator.
  4. /System/Library/LaunchAgents - OS X Per-user agents
  5. /System/Library/LaunchDaemons - OS X System wide daemons

If you find a file referring to uninstalled app, remove it (you'll need to sudo rm for items in 3, 4 & 5).

More about those files in http://developer.apple.com/library/mac/#documentation/MacOSX/Conceptual/BPSystemStartup/Chapters/CreatingLaunchdJobs.html especially 'The launchd Startup Process'.

2
  • Add /Library/LaunchAgents und /Library/LaunchDaemons to your list and be aware of different content for normal user and root ;-)
    – strauberry
    Aug 1, 2012 at 10:55
  • I focused on user context because that was pointed in console entry you wrote. But, you're right, the answer should be broader. So I did it. Is it written clear enough? Aug 1, 2012 at 12:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .