So this happened a while ago, and I thought it would resolve itself eventually, but it hasn't, so I'll just ask here. I was updating my apps and clicked the "Update All" button in the App Store. However, the applications didn't update; the loading bar showed up on the applications but no update progress is being shown. Additionally, below the loading bar is the name of the application which is unusual, as when an application updates, "Waiting...", "Loading...", or "Installing..." are shown. Here's an image:

enter image description here

You can see an example of the problem in the upper right corner with the "Dictionary.com" and "Movie" apps. This is happening to many apps, though, not just these two.

So far, I've only tried restarting the phone. I'm pretty sure that restoring will fix the problem, but I'm saving that as a last resort.

So basically my question is, is it possible to fix this without restoring and if so, how?

I would say "thanks in advance", but I've just learned its considered rude (see here: https://meta.stackexchange.com/questions/98149/why-is-it-considered-rude-to-say-thanks-in-advance), so I guess I'll just say "Thanks for taking a look at my question".

Device information:

  • iPhone 4S
  • 32GB
  • 5.1.1
  • Why the down vote?
    – pasawaya
    Commented Aug 9, 2012 at 3:18
  • ^No idea. I've had the same issue on my iPad. It started when I lost internet connectivity in the middle of an update.
    – Matt
    Commented Aug 10, 2012 at 7:26
  • @Matt - Did you fix it?
    – pasawaya
    Commented Aug 10, 2012 at 11:39
  • Not yet. I'm travelling, and I don't have the iPad to test ideas with. What happens when you sign out and back into the App Store?
    – Matt
    Commented Aug 10, 2012 at 11:41
  • @qegal, did you try my suggestions? David
    – ICL1901
    Commented Aug 14, 2012 at 4:26

2 Answers 2


This happened to me on my iPhone. I let it slide for a couple of weeks but then I decided to troubleshoot it. Signing out and back in to my store account, and then getting updates again fixed it. Here's how I did that:

  1. In the App Store app on the Featured tab, scroll down to the bottom and tap the 'Apple ID: _______' button
  2. In the pop-up menu tap the Sign Out button
  3. Tap the Sign In button, choose Use existing Apple ID, and sign in with your credentials
  4. Tap the "Updates" tab to find those updates again
  5. Update all of them again
  • I too have used this solution and it worked. Seems like iOS just needed a little nudge.
    – jtreser
    Commented Aug 14, 2012 at 12:11

i also have had this issue.. I believe that there are a few ways that you can try:

  1. (At the risk of sounding like Roy in "The IT Crowd", try turning it off and on again. See if the downloads resume.

  2. Connect to iTunes, update all the apps in iTunes, and then sync.

  3. Remove the apps from your device. Then go to #2. There is an option in iTunes to load apps that are not on your device.

enter image description here

I hope this helps.

  • Sorry, that didn't fix it.
    – pasawaya
    Commented Aug 14, 2012 at 14:35
  • Did you really power down? You can also plug into iTunes and do a restore. Connect your phone to iTunes, Highlight your phone and select restore. Once restored to factory settings, it will load from the latest backup. You can then sync with all apps in iTunes.
    – ICL1901
    Commented Aug 15, 2012 at 1:16
  • I did power down, and I'm aware that I can fix it by restoring (I said this in the question description), but the problem still persists. Anyway, thanks for your help.
    – pasawaya
    Commented Aug 15, 2012 at 16:26
  • oops. i forgot that.
    – ICL1901
    Commented Aug 15, 2012 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .