57

I have both an internal and external keyboard but the key-repeat has stopped working. I've tried changing both 'Key Repeat' and 'Delay Until Repeat' as shown below but no setting seems to be helping.

enter image description here

This is a brand new mac (5 weeks old).

7
  • 1
    What OS are your using? Did you recently upgrade to Lion/Mountain Lion? What computer model are you using?
    – de_an777
    Commented Jul 31, 2012 at 21:29
  • updated with the fact it is new Commented Jul 31, 2012 at 23:12
  • And repeat used to work, but now it doesn't?
    – Daniel
    Commented Jul 31, 2012 at 23:17
  • 2
    Try this command: defaults write -g ApplePressAndHoldEnabled -bool false
    – pasawaya
    Commented Aug 1, 2012 at 7:59
  • 2
    I have the same problem, and my Mac is new from 3 days ! I have Mavericks. Key repeating was working, but not fast enough to my taste. So I went to the Keyboard System Prefs, and now key repeating has stopped working. Commented Dec 1, 2013 at 10:39

3 Answers 3

59

Well it looks like there are a couple solutions:

Option 1. Enter this in terminal: defaults write -g ApplePressAndHoldEnabled -bool false. To disable repeating keys again, enter the same command except change the false to true.

Option 2. Download Mountain Tweaks (I assume you're on Mountain Lion, if not, download Lion Tweaks) and click the "Yes" option for "Enable Repeating Keys":

enter image description here

4
  • 4
    Don't forget to reload applications you use so as to allow this feature to take effect. They don't catch this option "on fly" quite often
    – Nick Roz
    Commented Jul 11, 2016 at 12:35
  • application restart is definitely necessary Commented Dec 30, 2016 at 10:09
  • Weird that tinkering with 'Key Repeat' speed in sys prefs didn't fix this. But the line of code in terminal did, for me anyway.
    – stevec
    Commented Feb 8, 2021 at 16:40
  • 1
    FYI the restart is not necessary in BigSur, also this is an insane setting..... Commented Aug 11, 2021 at 3:47
17

If running

defaults write -g ApplePressAndHoldEnabled -bool false

seems to have no effect, try a restart. This seems to be necessary in more recent versions of OS X.

2
  • 1
    In my case it was enough to type "exit" in the terminal. That seems to have enabled the option globally.
    – laurent
    Commented Feb 14, 2018 at 15:37
  • {on Mojave) This works immediately in the terminal where the command was issued, but applications (Firefox, Word, etc.) need to be restarted for key repeat to work. Commented Nov 4, 2019 at 0:30
7

By default, on macOS (since at least OS X Lion), when you hold down a key, it will display a popup allowing you pick a special character if there are any assigned to that particular key: special char popup

If a key doesn’t have any special characters behind it and you hold it down, nothing will happen.

As stated in Apple's docs:

You can add accent marks and special characters to some letters. For example, click and hold the a key to type à, á, â or other characters.

If you set the Key Repeat slider to Off, special characters won’t appear when you hold down a key.

Set how quickly a key repeats on Mac

To disable special characters popup and return traditional behaviour with key repeat, run following command in Terminal:

defaults write -g ApplePressAndHoldEnabled -bool false

Then restart applications (or computer) to update settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .