In older OS X versions, this used to work just fine:

defaults write /Library/Preferences/.GlobalPreferences com.apple.mouse.tapBehavior -int 1

It would enable tap to click for built-in MacBook Trackpads for the root user, which would also affect the login screen. There are similar commands to enable it for Bluetooth-based Magic Trackpads as well.

Unfortunately it doesn’t seem to work in OS X 10.8 anymore. Is there some other way of doing this in Mountain Lion?

  • Why the downvote? Commented Aug 30, 2012 at 6:31
  • 2
    And why not down votes and comments on the wrong answers below that haven't been tried / don't actually work?
    – bmike
    Commented Nov 7, 2012 at 14:47

7 Answers 7


Turns out you can add this as a function in the Terminal:

sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

That worked for me, thanks to these guys - http://forums.macrumors.com/showthread.php?t=1218257

  • This worked for me on a MacBook Air running 10.8.4, both with the built in trackpad and a bluetooth Magic Trackpad.
    – Mr Rabbit
    Commented Aug 7, 2013 at 12:28
  • This worked for me with Retina MacBook Pro on OS X Yosemite (10.10.2) with Magic Trackpad. Thank you!
    – U007D
    Commented Mar 18, 2015 at 4:21
  • Didn't work on my rMBP 13" with 10.10.2. Commented Mar 26, 2015 at 4:55

I've had mixed results with enabling it for the login screen between my macs.

Here's how I have gotten it to work:

  1. Go to System Preferences (as an admin user) -> Users and Groups -> Login Options
  2. Click the lock and enter your admin credentials
  3. Next to Network Account Server click Edit (or add, what ever comes up if you don't have a server already set up) and then click "Open Directory Utility"
  4. Click the lock again and reenter your credentials
  5. In the menu bar, click edit and then click "Enable Root User"
  6. Set up a password for the user, and then log out of your current user
  7. At the login screen, you should have a "Other..." option next to your users. Type in "root" as your username and use the password you set up.
  8. Enable tap to click through System Preferences.
  9. Log out, and go back into your normal user, and open up Directory Utility again
  10. Click on the padlock to authenticate in Directory Utility, and then go to edit on the menu bar, and click "Disable Root User"

For security's sake, make sure you disable the root user!

Now I mentioned at the start I've had mixed results for this. It worked fine on my Mac Mini 2012, but it didn't seem to work on my MacBook Air 2011. The thing that I can think of primarily is that the MacBook Air's trackpad is built in and connected via USB, whereas the Mac Mini's trackpad is bluetooth.

Why does this matter, you ask? Did anyones else notice that the Terminal command that was used to change the system default to having Tap to Click on seems to store the setting in an entry that references AppleBluetoothMultitouch.trackpad?

If thats the reason, then that would be why some people report the terminal command works and others say it makes no difference.

I'm going to dig more in this, I wonder if there is a similar AppleUSBMultitouch.trackpad entry somewhere...


  1. Just confirming, I connected my Bluetooth Trackpad to my MacBook Air (it is surprisingly difficult to remove a trackpad from bluetooth preferences on a desktop mac by the way) and I can Tap to Click on the login screen with the bluetooth trackpad, but not the built in one. Innerestin'!

  2. Oh, for comparison to your systems, both my Macs are running 10.8.4, have no startup items at all (I like my speedy boot times) and have no third party Kexts

  • Tried this, tried the terminal commad with com.apple.AppleMultitouchTrackpad Clicking 1, neither worked on my rMBP 13" OSX 10.10.2. Commented Mar 26, 2015 at 4:57

On 10.8 the correct wording seems to be

sudo defaults write com.apple.AppleMultitouchTrackpad Clicking 1

(not sure if the -int switch is really needed). This does not turn on click-to-tap immediately and if somebody can tell how to apply that default, i'd be a happy little admin :)

  • I'd say -int is not needed, works here just fine without.
    – Jawa
    Commented Nov 1, 2013 at 13:19
  • +1. I tested this on my 2014 Macbook Air with OS X Mavericks and it works. Note that sudo is needed even if you are using an admin account. (Before I changed the defaults, I opened the terminal from an admin account and typed sudo defaults read com.apple.AppleMultitouchTrackpad Clicking and then repeated the same command but without sudo. The former reported 0 while the latter returned 1.) The -int in -int 1 is to specify that 1 is an integer. Apparently the switch can be omitted but it doesn't hurt to include it. One may also replace the part -int 1 by -bool true.
    – user1551
    Commented Jul 13, 2014 at 5:51
  • Anyway, in view of Howard's answer, it seems that one needs to change different domains/keys on different versions of the OS or different models of machines.
    – user1551
    Commented Jul 13, 2014 at 5:52

Have you tried enabling dragging in System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options?

(From How to change tap to click using "defaults write" from command line?)

  • Dragging doesn’t seem to have anything to do with this. I also don’t see any reference to this setting in the thread you linked to. Commented Jul 30, 2012 at 10:59

I haven't tried this myself, but this might be what you're looking for: sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1

  • 1
    Just want to point out the following command does not work in 10.8 sudo defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -int 1
    – user26612
    Commented Aug 2, 2012 at 16:57
  • 1
    I found that one on MacRumors as well — but it doesn’t seem to work on OS X 10.8 either. Commented Aug 6, 2012 at 17:27

Are you talking about the "Tap to click"? If so you can enable and disable in

System Preferences > Trackpad > Tap to Click

  • At least for me it has changed. I'm using Mountain Lion
    – J. Costa
    Commented Aug 30, 2012 at 9:59
  • Not for me. This only changes the settings for the current user, not the login screen. Commented Aug 31, 2012 at 6:32

System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options > check Enable Dragging with/without Draglock.

  • What does this have to do with the issue at hand? How can this work? Commented Oct 11, 2012 at 6:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .