Problems following an upgrade to Mountain Lion on a 13-inch, Early 2011 MacBook Pro (MacBookPro8,1 with Intel HD Graphics 3000).

With Google Chrome, I was watching YouTube video fullscreen – Flash content. In the middle of video, I wanted to exit full-screen mode but neither the keyboard nor the trackpad worked. The video continued playing fine. At last, I forced the system to close and restarted.

Today I was just chatting in Messages and suddenly everything froze. I was able to move the cursor but nothing was happening.

Has anyone else faced this issue, or found a solution?

Update: If I connect my mobile phone (HTC Wildfire S) to my MacBook Pro using USB, the Mac freezes every time while removing the USB connector.

  • Duplicate of my question: apple.stackexchange.com/questions/58197/…
    – Caesium
    Commented Jul 29, 2012 at 10:59
  • I get this upon a reboot when I open an app sometimes. At first I thought it was Microsoft Lync causing the issue, but I've since had it with Firefox and Evernote. Upon a forced reboot all is well, but I don't like doing this.
    – AlanJC
    Commented Jul 30, 2012 at 21:17
  • A very similar question but @Caesium is happy to work remotely with ssh. As we can't assume the same here, answers may offer a subtly different approach. Commented Jul 30, 2012 at 21:58
  • @Vivart, please: what model is your MacBook Pro? Which browser did you use? Do you prefer Flash or HTML5 for video in YouTube? A combination of factors may contribute to this case. Commented Jul 30, 2012 at 22:01
  • @GrahamPerrin i have 13-inch, Early 2011 macbook pro. I was using chrome browser for flash video on youtube.
    – Vivart
    Commented Jul 31, 2012 at 9:10

2 Answers 2


Suspect an issue affecting the WindowServer process (long edition)

The symptoms you describe are familiar but not commonplace and in my case, not frequent.

Prepare for diagnosis

In Terminal, run the following command. Be prepared to enter your admin password for the operating system:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.stackshot.plist

Take a written note of the following key chord, you'll need it later:


Diagnosis by the system

When the problem occurs:

  1. use the key chord
  2. for at least ten seconds, touch nothing
  3. allow maybe five or ten minutes for all parts of the so-called sysdiagnose routine to complete – simply wait as long as you can (with this approach there'll be no on-screen indication of progress)
  4. force a restart of the computer (Command-Control-Power).

After the computer starts:

  1. in Finder, go to /private/var/tmp
  2. seek a file or folder with a name beginning sysdiagnose_
  3. if that file or folder exists, move it to a convenient place – your desktop, maybe.


Whilst I don't encourage carelessness, you can be a little careless with Control-Option-Command-Shift-. … if you struggle to avoid the fn key on your laptop, don't worry; including it by accident should not prevent the run of sysdiagnose.

Human analysis of diagnosis by the system

Hint: someone might like to ask a separate question about analysing the results of sysdiagnose – a more generalised answer could be useful.

If sysdiagnose_… from the /tmp area is a folder

Presence of a sysdiagnose_… folder (not a .tar.gz file) indicates that either:

  • the routine was interrupted before completion; or
  • some part of the routine could not complete.

If sysdiagnose_… from the /tmp area is a file

Presence of a sysdiagnose_….tar.gz file indicates that all parts of the sysdiagnose routine completed, and that the results were archived. If you wish, open the archive – its contents will appear as a folder.

Folder contents at a glance

In the first screenshot below – an example of a completed run of sysdiagnose - I have selected two of the items that may be of interest in a case such as this.

Screenshot of a decompressed sysdiagnose_….tar.gz archive

Note that it may be normal to find at least one empty file.

crashes_and_spins gathered by sysdiagnose – screenshot of an example

Amongst the .crash, .hang and .spin files – or in the top.txt file – might be a good sign of what was wrong shortly before, or during, the period when you lost control of the computer.


For an incomplete run of sysdiagnose it may be useful to focus some attention on files that are abnormally empty …


stackshot(1) OS X Manual Page

sysdiagnose(1) OS X Manual Page

  • I have tried this and i got a folder in /tmp with bunch of files.
    – Vivart
    Commented Jul 31, 2012 at 9:28
  • Thanks for the acceptance. If eventually you discover the cause(s) of the problem in your case, I'll be glad to know - please leave a comment either here, or under your question. Commented Aug 15, 2012 at 5:05

This is because of the Android File Transfer App. Uninstall it and the problem will go away.

Still I think google should address this..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .