I have a Lion installation dual-booted with Ubuntu using refit. Upon trying to upgrade to Mountain Lion, I reboot into the mountain lion installer, and get a message about OS X not being able to be installed on this disk since it can't be booted.

How can I recover from this situation? My machine is not having a problem being booted (I can work around that).


4 Answers 4


I also had this problem (on a 2012 MBA). Running rEFIt's partition table tool and accepting the "update the partition table" dialog it offered fixed it for me. (The Ubuntu install instructions at https://help.ubuntu.com/community/MacBookAir4-2 do tell you to do this to resync the partition tables; but not doing it didn't seem to cause a problem at the time.) For me the only partition table change it made was to change the type of the recovery partition to Apple Boot: probably best to look carefully at what it is proposing on your system before accepting it.

  • I think the version of refit that I have does not have the resync option anymore. I'll have to look into why that is. thanks for posting.
    – dpb
    Jul 30, 2012 at 16:32

Basically, I ran into the issue discussed on the apple message board. One of the partitions had been altered (probably by rEFIt), and I had to "fix it". I'll list the steps I went through while troubleshooting. I guess it goes without saying you should have good backups before you do this. Not an issue for me.

  1. I'm running a MBA 2011, one internal disk, 6 partitions on it in total.
  2. I repaired the disk with disk utility, reboot (not sure that this did anything).
  3. I tried to use fdisk -u /dev/disk0, reboot (not sure that this did anything).
  4. I tried an article about resizing a partition with disk utility, it didn't work. Some error about wrong partition type, even though it was an HFS+ partition.
  5. I installed gptfdisk -- installed using brew brew install gptfdisk. I'm sure you can get it another way.
    • once installed, you run with sudo gdisk /dev/disk0
    • find your "Recovery Partition", for me that was partition 3 i <CR> 3 <CR>
    • Change the type t <CR> 3 <CR> to Apple Boot
    • Write the table w <CR>
    • Reboot
  6. Upon reboot I could successfully upgrade to mountain lion

To get Ubuntu back booting I had to do a combination of fixing up the MBR, and re-installing grub to /dev/disk0 (/dev/sda in ubuntu) which should be familiar to most people. For my case (Macbook air 4-2), I had to follow ubuntu's instructions (skipping things associated with installing the OS of course), especially the part about the bios_grub partition. This must be something that was done for me in the past, since this is the first I remember seeing it.

  • HI! I had the same problem, but things went a little differently for me. MBA 4-2. The resizing a partition with disk utility worked and I could install Mountain Lion. Even refit was still available. However I now see "Boot Legacy OS" and get "Missing Operating System". So I tried the ubuntu instructions but cannot get anywhere. I synced the par-table with refit. Could you elaborate on how you reinstalled Grub? Cheers
    – wpp
    Dec 4, 2012 at 15:05
  • Thank you for this tip! My problem wasn't the type label on the Recovery HD, but rather the type label of my Ubuntu-written EFI system partition. I used gdisk to re-label it from 'Microsoft basic data' to EFI System (code ef00). Once this was done, Disk Utility didn't report a missing EFI system partition anymore, and I could run "Validate Disk" and "Repair Disk", which set me up fine for the Mountain Lion install. The 'OS X cannot startup from this disk' problem was subsequently gone. Oct 25, 2013 at 23:37

I ran into the same problem today with my new retina mbp. And while trying to fix it I remembered having the same problem last year while upgrading OSX on my girlfriend's ubuntified mba 2011...

The thing is that (during install) there needs to be some free space after the OSX partion. (http://support.apple.com/kb/TS3926)

I did not manage to resize the OSX partition using the disk tool, but booting Ubuntu and using gparted I had no problem making it a couple of hounded megs smaller.

Now the install seems to run just fine... "15 minutes remaining" as we speak.

  • Thanks Jon, this could have been the issue. My drive is maxed out for sure. One of the major issues seems to have been the bios boot partition that comes right after the mac os x partition, which got messed up. I will annotate in my answer. I can't confirm what you said exactly, but it's a good data point.
    – dpb
    Jul 30, 2012 at 22:00
  • The install is now complete and all is well... just had to re-enable refit. Before remembering the free-space-needed trick I did what you suggested dpb: I changed the partition type for the Recover partition to Apple Boot. Maybe that was necessary too?
    – Jon
    Jul 30, 2012 at 22:26

Just had a similar experience, but resolved it differently.

I created a "Lion" partition to install the new OS, leaving my old leopard partition in place. This made my partition list look like: Leopard Lion (Note -- even though the Lion partition looks like it is the last partition in the list, there is actually a hidden Apple Recovery partition, unmounted, as the last partition. You have to enable the disk utility debug menu to gain access to the hidden partition)

Lion installed fine, but I didn't have enough room for everything I wanted to move to the new OS, so I started tinkering with partition sizes.

While trying to resize/expand the partition for Lion, I removed the hidden disk recovery partition. This made the Lion partition the last partition in my disk partition list.

Trying to re-install Lion gave me the "this disk can't be used to start" message. On a hunch, I created a small partition from the bottom of my Lion partition, so that the Lion partition was (once again) NOT the last partition in the list.

This fixed the issue. The installer suddenly allowed me to install to the "Lion" partition.

To summarize, one of the situations which will prevent the installer from installing to a disk partition, is if it is the final partition in your partition list, including the hidden partitions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .