53

I set my input source to be US English. And the flag showing on the taskbar is also an American flag.

But whenever I type something in Mail.app or Notes.app the spell check still corrects my spelling to British English:

  • e.g. it highlights my "organize" and suggest s"organise".

Please, how to make my Mac (OS X 10.8) an American?

37

For OS X 10.8:

System Preferences > Languages & Text > Text > Spelling

image of control

Or for OS X 10.9 and later:

System Preferences > Keyboard > Text > Spelling

64

To add to what gentmatt said, in the case you need to keep "Automatic by Language" because you happen to write in different languages, click on "Set Up…" in the list shown for the Spelling option.

screenshot

On the dialog box that appears, you can change the order for the languages. In my case, this is the order I chose.

screenshot

Now, I can write organize, and the word is not corrected, nor do I get a suggestion for writing organise. (It happens that organise is shown as incorrect.)

4
  • and for snow lep? Mar 25 '13 at 19:13
  • 2
    In Mavericks, you can get there via System Preferences -> Keyboard -> Text -> Spelling (or Language & Region -> Keyboard Preferences -> Text -> Spelling).
    – djc
    Feb 18 '14 at 10:01
  • Thank you, this one is the answer I was looking for as a non-native English speaker/user.
    – karni
    Apr 20 '18 at 16:25
  • 1
    Wow! The "Set up..." for this is well hidden! May 28 at 9:24
12

In Mavericks (10.9):

System Preferences -> Keyboard -> Text -> Spelling

or

System Preferences -> Language & Region -> Keyboard Preferences -> Text -> Spelling

2
  • This should be a comment or an edit adding to a previous answer as it is the same just via a different menu route
    – mmmmmm
    Nov 25 '13 at 15:46
  • 3
    Actually, it was helpful to me having this as a separate answer as the previous answer references the non-existent (in Mavericks) UX path "System Preferences → Languages & Text → Text → Spelling" path.
    – easyE
    Sep 10 '14 at 7:47
4

Autocorrect with multiples languages (automatic by language) in Mavericks is broken. It does not underline all the bad written words. I have to select only 1 language to get it properly working.

1
  • Evidence? I'm not finding this to be the case. Dec 14 '14 at 13:23
0

What worked for me is:

Go to "System Preferences" -> "Language & Region".

Under "Preferred languages" add "English (US)" and remove "English".

This changed the spell checking from British English to American English.

1
  • Regardless of what you have set in Preferred Languages, spellcheck in Apple apps can be set to either US or UK English, or French, or Spanish or whatever via System Preferences > Keyboard > Text > Spelling (or in the app via Edit > Spelling and Grammar > Show Spelling and Grammar Apr 10 at 20:16
0

These answers were great for the most part but have slowly aged out of date after ten years. I'm currently on Mojave 10.14.6 here. The global option remains in the Text section of the Keyboard preference pane but that section has mostly been taken over by text expansion. Spelling has moved so here's a couple of screenshots to pilot you in:

Keyboard Text Preference Pane Mojave 10.14.6

Set spelling language expanded

One can set multiple languages. Here's the ones I have set:

Set multiple languages via checkbox Mojave 10.14.6

You can also change the language for spelling while in an application.

setting the spelling language from within in an application

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .