I have just upgraded to OS X 10.8 Mountain Lion and am attempting to use Facetime and iMessage. Upon entering my Apple ID into the respective applications and attempting to sign in, I receive the following error message:

The server encountered an error processing registration. Please try again later.

Whilst I assume that imagent proceeded beyond the authentication stage (as providing incorrect credentials results in a different error message), I am unable to ascertain exactly what went wrong. I cannot find any log file (nor any option to enable logging) that shines light on the subject. Is it possible to audit imagent activity?

I have found various suggestions, some of which appear to have worked for others:

  1. Force quit the imagent process;
  2. Reset /etc/hosts to default state;
  3. Enable ntp;
  4. Fix permissions and/or delete ~/Library/Preferences/com.apple.imagent.plist;
  5. Delete certain Apple-issued certificates from the user's login keychain;
  6. Use Google's public DNS resolvers;
  7. Disable all firewalls and packet filters;
  8. Delete the contents of /Library/Preferences/SystemConfiguration;
  9. Reset NVRAM/PRAM;
  10. Reboot.

I have tried all of the above, with no improvement.

I have tried using two different Apple IDs: one a simple MobileMe account (ending @me.com) that has been transferred to iCloud; the other an old .Mac address (ending @mac.com) with which additional non-Apple email addresses have been associated and verified. The computer is connected to iCloud with the former account; and I have previously used the latter account successully with Facetime on the same computer (when running Lion) and with iMessage on my iPhone and iPad.

I am at a loss to understand how I should proceed. Whilst I would be grateful for any suggestion that fixes the problem, I would be far more grateful for a canoncial answer that describes how imagent issues can be debugged in the future: e.g. how to enable logging or similar.

  • I have the same problem and so far found no solution.
    – GM.
    Jul 28, 2012 at 1:16
  • Do you mind editing the question's title a bit? I'm sure that many people will google this problem by merely using something like this. Then this question only pops up on the second page.
    – gentmatt
    Aug 1, 2012 at 11:31
  • I'd prefer for the title to contain the error message "The server encountered an error processing registration." as well - hoping that this will get ranked higher by google. This question got answered! More people should get to see this post.
    – gentmatt
    Aug 1, 2012 at 11:32
  • I've started a discussion about this in chat.
    – gentmatt
    Aug 1, 2012 at 11:33
  • I guess it would help to put "The server encountered an error processing registration. Please try again later." in the title. It's a more or less "popular" string in the Google search field :-).
    – GM.
    Aug 1, 2012 at 19:56

1 Answer 1


I removed the file


and after a reboot the error

The server encountered an error processing registration. Please try again later.

was gone (Mac OS X creates a new 'NetworkInterfaces.plist' file during the boot process).

The file


contains informations about the network interfaces, it looks like the upgrade from 10.7 to 10.8 broke something (at least on my system).

'imagent' itself has no debug option but you can try tools like


or the


to monitor the program. Instruments.app is part of XCode and a GUI to dtruss.

Or you can monitor the network traffic between imagent and the server.

  • Thanks for the suggestion; however it sadly did not work for me: indeed, the newly-created NetworkInterfaces.plist is identical to the old one.
    – eggyal
    Jul 31, 2012 at 8:53
  • Remove all files inside the folder /Library/Preferences/SystemConfiguration/ (before you do this create a backup of the folder) and then reset the NVRAM (This URL support.apple.com/kb/HT1379 explains how you do this).
    – GM.
    Jul 31, 2012 at 12:31
  • Another idea is to check if something blocks the ports of the 'imagent', do you use programs (IP-Filter) like 'Hands Off!' or 'Little Snitch'? An IP-filter maybe blocks the outgoing connection. And turn of the Mac OS X 'Firewall", just to make sure that nothing blocks the ports of the 'imagent'.
    – GM.
    Jul 31, 2012 at 12:36
  • Thank you for your further suggestions; however sadly none of them have worked for me. I deleted all files and folders in /Library/Preferences/SystemConfiguration, disabled my EFI password (couldn't find a way to reset PRAM with it enabled), reset PRAM, reenabled my EFI password, rebooted, disabled both OS X firewall and Little Snitch packet filtering... but I still get the same "error processing registration". Grateful for any thoughts you might have on how to debug what is happening, rather than stabs in the dark at potential solutions.
    – eggyal
    Jul 31, 2012 at 13:44
  • Check imfreedom.org/wiki/IMessage for informations about how iMessage works and maybe you can use the tools I mentioned above to monitor the programs. It looks like that 'applepushserviced' is responsible for the connection, you can turn on debug logs for this program (how you do this is described in the link). I saw that 'applepushserviced' has a keychain '/Library/Keychains/applepushserviced.keychain' you can check if this keychain is maybe corrupted on your system.
    – GM.
    Jul 31, 2012 at 23:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .