I would like to install Windows 7 with Boot Camp on my 20 Inch iMac 8,5 from late 2008. My Superdrive seems to have failed, inserting a DVD or CD just results in it spinning a bunch clunking about and spitting it out. So I need to use the USB method to install.

I have tried the following methods of creating a bootable USB to various USB devices in s 4GB & 8GB and had zero success in booting them:

  1. Boot Camp USB Creator directly from Boot Camp (I edited the .plist to allow this)
  2. Unebootin (Linux distros won't boot either)
  3. Windows USB Maker from a Parallels install of Windows 7 (the same ISO)
  4. Terminal "sudo dd..."
  5. Disk Utility converting the ISO to an IMG and successfully restoring it to the usb partition
  6. WinToBoot and various other Windows applications to wipe and write the iso via Parallels Windows installation
  7. rEFIT both directly on my mac and as a bootable usb, the bootable usb is recognized and sees the Windows usb but when launched it simply says no bootable device

I have also tried to do a simple linux install usb with Unebootin with no success in booting. I have created a bootable Mac OS install usb using Disk Utility which is recognized when holding Option.

I am starting to wonder if it is my computer or EFI firmware? All the USB ports work fine with other peripherals and recognize the usb devices when Mac OS or parallels is open.

As of yesterday I am running Mountain Lion (I'd hoped perhaps updating would make something work) made no changes.

  • No one has ANNNY possible answers or suggestions?
    – nexionly
    Commented Jul 28, 2012 at 0:35

1 Answer 1


I think the problem is the way the computer is locked, if your computer has a Super Drive, your Mac is automatically configured/locked to boot from that drive and ignore the USB.

Their is no amount of reconfiguration or software tricks that would change that, what you can do is take out the Super Drive, or try cleaning it with a CD cleaner - the one with the brush.

  • Citation needed. Macs can boot off USB, but maybe not Windows due to the way EFI is implemented.
    – lid
    Commented Apr 4, 2014 at 8:05
  • I am sorry I got it Fixed it was as you said , the way the boot stick was done , i had to use windows utility in order to install windows on a usb and from there all went ok .
    – Wafic
    Commented Apr 10, 2014 at 10:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .