I am getting the following message from Xcode every time I connect my iPhone to Mac OS X.

The host is no longer paired with the device.

My iPhone doesn't even charge.

  • 1
    Is that the exact error message? It doesn't sound like a standard error message. – g . Jan 2 '11 at 17:17
  • Yep ! Boss (@g.)- It's the exact message that I got. The message was from XCode. – Sagar R. Kothari Jan 3 '11 at 4:48

I really, really, really hate to say this; but, in my experience, it works for this kind of thing: Restart your iPhone (home+sleep for a few seconds) and try again.

| improve this answer | |
  • Sometimes, restarting the OSX as well will be needed. – cregox Jan 2 '11 at 23:21
  • G. - I couldn't believe, It worked. Great. :) – Sagar R. Kothari Jan 3 '11 at 4:49

May be it's because you use software such as Parallels Desktop, that hook USB devices, when you plug in...

| improve this answer | |
  • Yehh ! But I didn't even install such softwares. I think that iPhone Cable got some problem. I tried with different cable & it worked fine. – Sagar R. Kothari Jan 30 '12 at 8:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .