61

I've got a MacBook Pro 13" with Lion plugged into an external VGA monitor. Often, when I unplug its video dongle deal, the MacBook doesn't realize the other monitor is gone. It continues to believe it's the Secondary Monitor (which I can confirm by right-clicking the desktop and selecting "Change Desktop Background...").

There's no menu bar, so I can't get to my Display icon to Detect Displays. No, I don't want the MacBook screen to be the primary when I'm on the external.

Plugging the DisplayPort dongle back in does nothing. It won't even re-display on the external monitor it was hooked up to before, so no mirroring kludge if I forget. To this point, I hard power down and restart.

Any idea how to tell the MacBook there's no external monitor and that it's the primary now?

  • 6
    Command + Brightness Up is the keyboard shortcut for Detect Displays, but that option is gone now in ML. – vcsjones Jul 26 '12 at 14:14
  • @vcsjones he said he is on Lion, which should clear his problem! – Philippe Gilbert Jul 27 '12 at 0:18
  • @vcsjones -- might want to turn that into an answer. Seems to do the trick in 10.7. – ruffin Aug 1 '12 at 18:32
  • @ruffin Added as answer. – vcsjones Aug 1 '12 at 18:43
66

Command + Brightness Up is the keyboard shortcut for Detect Displays in Lion.

  • 10
    On my MBP with ML, It turns out that Option + Brightness-Up turns on detect displays. – user26557 Aug 1 '12 at 23:02
  • 7
    Jumping into this conversation 2.5 years later (HELLO PEOPLE OF THE FUTURE) to say that this also works a treat in Yosemite. – Scottie Feb 17 '15 at 15:57
  • 3
    Have been getting this in El Capitan and Option+Brightness-Up helped me to get into the Settings window (which itself was difficult before as explained by ruffin's comment). I got the option to gather all windows, but that didn't make any difference, and Mac continued to behave like there is an external monitor. I was clicking on random options to see if it helps, and when I clicked on "Mirror displays" option, my display became blank and soon Mac itself crashed. – haridsv Aug 30 '16 at 12:36
  • 7
    Is there a way to do this on a 2016 MacBook Pro that has a Touch Bar instead of brightness controls? – Carlos Macasaet May 2 '17 at 16:57
  • 1
    Jumping in 6 years later...It still works in Mojave. This works like a charm!! – Gowtham Raj Oct 12 '18 at 4:44
20

Another way to do this is by going to Displays in System Preferences and then holding down the ⌥ Option key and the Gather Windows button will turn into a button that says Detect Displays.

  • Thanks, the accepted answer isn't much help if you have a Windows-style keyboard connected... – James B Sep 21 '15 at 17:22
  • 1
    This answer is obviously working for some folk, but in my original situation, you couldn't get to Settings. You could open it, but the Mac thinks it's displayed on the now-missing "primary display". /sigh @JamesB -- Fwiw, since the question is about a MacBook, and it's difficult to take the Mac keyboard off ;^D, the accepted answer works great. Would be a pain if what I'm seeing happened on an iMac, though it sounds like you're seeing something different. – ruffin May 12 '16 at 13:55
  • I had this problem on an iMac, yes. We don't want the kids wrecking our "nice" wireless aluminum keyboard so we have a cheap Windows USB KB hooked up for day to day use. – James B May 14 '16 at 19:03
  • 1
    This works well on machines with a touch bar. – guaka May 6 '17 at 13:03
  • I have unplugged ant tried this, but osx still thinks my 5k is plugged in… Pretty damn annoying bug. Do I have to reboot? – Viktor Hedefalk Jun 12 '17 at 14:29
15

I've had this with Mavericks a few times, and I found out that in my case changing the Rotation will trigger the OS to recognise the monitor(s) aren't there. Changing the resolution or some other action (besides obvious reboot) didn't seem to work for me.

  • 1
    Oh thank god, it works in Yosemite too. If I could buy you a beer, I would. – Jay Jun 13 '16 at 23:57
  • Wow, this is pretty cool. Also worked for me. What a hack. – jontsai Sep 13 '16 at 2:54
  • 1
    I had the issue on macOS Sierra 10.12.4 on a rMBP. And this hint worked! All other hints presented in this issue failed: "Detect Displays" via "CMD + Brightness Up" did nothing. "CMD + Brightness Down" showed the external screen content on the internal screen, the same keystroke again switched back to internal display. System Preferences > Displays: Hold down ALT so that the button "Gather Windows" change into "Detect Displays" and then clicking it, also failed. – porg Apr 29 '17 at 8:10
  • Nevertheless the discrete GPU remained active, and only a restart switched back to integrated graphics. – porg Apr 29 '17 at 23:15
  • This works on the High Sierra beta as well (in my case it's a HDMI monitor). – Andrea Lazzarotto Aug 16 '17 at 0:14
2

None of the other options worked for me on my El Capitan MBP, but putting it to sleep and waking it up immediately worked like a charm.

  • This has been my workaround, however 30% of the time the Macbook doesn't wake up (must power cycle) and I lose all my SSH sessions, and have to recover unclosed vi sessions. My company issues us 13" laptops for development (Mac or PC), but I'm about ready to use my own money to buy a 17" Lenovo running Ubuntu (at least then, it'll also fix my terminal hotkeys like control-d back-word navigation) – Crossfit_and_Beer Jan 21 '17 at 15:24
0

I've had a similar issue, (though I'm using the HDMI port on my 13 inch MacBook Pro Retina to run my external monitor - the overheating and wifi interference hassles with Thunderbolt that drove me to use the HDMI port are for another thread...) and have, thus far found that powering down the monitor I'm using (a Dell 4K HD powered by a 110 appliance plug) then waiting a minute or so before unplugging the HDMI connector from my MBP usually sends the right message to the computer and gets me back to the single screen.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .