48

Since re-installing OS X (10.8), every time I plug in an iOS device iTunes opens up and shows an error message:

iTunes could not connect to the iPhone "..." because it is locked with a passcode. You must enter your passcode on the iPhone before it can be used with iTunes.

I plug in various devices all the time, just so I can charge them. I do not want them connected to iTunes, I definitely don't want iTunes storing a copy of the device's passcode (or however that works) on my mac, and some of the devices plugged in aren't even mine.

How can I stop this from happening? It doesn't happen when I'm booted into 10.7 on the same mac, with the same iOS devices.

I already have "Prevent iPods, iPhones, and iPads from syncing automatically" enabled in Preferences.

EDIT: this particular device also has "Open iTunes when this device is connected" turned off, so it seems to ignore that setting.

40

Under System PreferencesUsers → [you] → Login Items → select iTunesHelper, then click the minus sign and log out/into your Mac.

No devices will cause iTunes to launch (that's the whole purpose of iTunesHelper).

  • 2
    Hiding iTunesHelper or clicking the minus sign didn't work for me. Do you have to restart your computer or log out? I also tried unlocking/locking (click the lock icon) on this same screen but that had no effect. Mac 10.7.5 iTunes 11.1 – tim peterson Oct 13 '13 at 16:33
  • 1
    @timpeterson yes you'll need to log out. Also I think iTunes might occasionally put it back. >:( – Abhi Beckert Oct 13 '13 at 20:30
13

In iTunes there is an option to prevent the app to launch when a device is connected to your computer.

Open iTunes > Clic on a device in the sidebar > Scroll down to the "Options" section.

Then you have to make sure this little checkbox is un-check: itunes option
(source: f.cl.ly)

If the problem still occurs after that, come back here !

  • That was already unchecked. Also, I need this to work on other people's devices as well including ones where they might have this setting enabled. As part of my work, I regularly plug other people's devices into my mac. – Abhi Beckert Jul 26 '12 at 0:26
  • 1
    I Think that this settings is save for your computer only and it don't affects other computer, but i might be wrong. – Lifely Jul 26 '12 at 9:16
  • It was already turned off and I just did a clean install. So it must be stored on the device. – Abhi Beckert Jul 27 '12 at 3:26
11

Open iTunes -> Preferences -> Devices.

Make sure Prevent iPods, iPhones, and iPads from syncing automatically option is checked.

enter image description here

enter image description here

  • 1
    This does not answer the OP's question. The OP has already stated in their question that this checkbox is already checked and yet the issue still persists. – Greenonline Feb 2 '16 at 3:34
  • This does contribute information to the problem, because I already had iTunesHelper eliminated but was still having this problem, doing this fixed it. – Michael Liquori Apr 18 '17 at 22:38
2

You need to disable iTunesHelper agent. The following command in Terminal can help:

launchctl stop com.apple.iTunesHelper
-1

The solution I found that worked since nothing else did for me was to rename the iTuneshelper.exe file before I plug in my iPhone. I use Explorer to get photos off my phone and this is the only way I could do that after I installed iTunes. Apple needs to really work on improving iTunes. I don't find it user friendly at all.

  • Renaming something doesn't seem like a solution, especially since when Apple performs updates, chances are it will update with the correctly named executable. – jamescampbell Aug 23 '18 at 13:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .