So I just upgraded to Mountain Lion, and I'm watching some Netflix over my Apple TV, when it stops streaming and tells me it's not connected to the network any more. Sure enough, my Air has also lost it's network connectivity and the Airport Extreme is solid Amber on the status light.

I wait a while, it starts to flash green, then it goes green, and slowly my SSIDs start to appear, and everything is normal again.

I presume the AE just rebooted, so I fire up Airport extreme to look at the logs, and remember that in Airport Utility 6.0, all the nice advanced features (and some not so advanced ones) are not available. Amongst them is viewing the logs. So I download 5.6, which is the most recent non-6.0 version that uses the old ways and lets you view logs etc - and it won't install because it's not compatible with Mountain Lion.

A bit of googling about also reveals that apparently V6.0 will only manage Wireless-N networks. Seems anyone with older Airport kit, or a need to do anything slightly advanced in ML is screwed.

Anyone know how I can either view logs in 6, or install 5.6 on 10.8?


9 Answers 9


If you do not want (or can't) get the app out of a backup you can extract it from the installer.

Download the Airport Utility 5.6 for Lion and move the file AirPortUtility56.pkg contained within the dmg to your ~/Downloads folder. Then in a Terminal window do :

$ cd ~/Downloads
$ pkgutil --expand ./AirPortUtility56.pkg ~/Downloads/AirPortUtility56
$ gunzip -c < ./AirPortUtility56/AirPortUtility56Lion.pkg/Payload | sudo tar -C / -xvf - "./Applications/Utilities/AirPort Utility 5.6.app"

The app works without issue on Mountain Lion in my limited testing so far.

If you wanted to mod the package to skip the check, if you want to easily install the package on multiple macs for instance, here's what you need :

A tool called "Flat Package Editor" to modify the file called Distribution in AirPortUtility56.pkg. To get that tool download the "Auxiliary tools for Xcode" from the Apple Dev site. It's hidden in PackageMaker.app/Contents/resources/Flat Package Editor.app. With it you can open the pkg directly :


Just drag out the Distribution file and remove these lines :

// Less than 10.8
if(-1 != system.compareVersions(my.target.systemVersion.ProductVersion, '10.8')) {
  my.result.type = 'Fatal';
  my.result.message = system.localizedString('ERR_OSHIGH');
  return (false);

Drag the new version back in, delete the old Distribution and save.

  • 1
    My 5.6 (for an old AirPort Express) was still there after upgrading to Mountain Lion, and I've meanwhile used to change the SSID, password, and AirPlay settings. Seems to work fine indeed.
    – Arjan
    Commented Jul 29, 2012 at 14:44
  • 1
    Nice example of how to bypass the installer checks. I've also seen people edit the preflight script (when it's a text or shell script) as well. I bet this would work to install most downlevel versions of the app.
    – bmike
    Commented Jul 29, 2012 at 16:55
  • In this case the relevant check seems to be in a script called Distribution inside the AirPortUtility56.pkg. I'll add instructions on how to mod the package to my answer.
    – Tyr
    Commented Jul 29, 2012 at 17:31
  • 1
    This is perfect. I even got so far as to fire up Lion in a VM to get this working! Thanks.
    – stuffe
    Commented Jul 29, 2012 at 22:07
  • 2
    Sadly it is no longer working with OS X Mavericks Commented Jan 31, 2014 at 11:22

I restored version 5.6 from my Time Machine backup of Lion and it works properly, however you should also be able to download it from Apple and extract the application from the .pkg using Pacifist.


I use Airport Utilty for Windows on my virtual PC in Vmware Fusion to configure advanced settings.


I too was unable to get any of the installers to install any older 5.x version of the utility onto Mountain Lion, but I did copy over AirPort Utility 5.3.3 from a Lion machine and it has been working fine for days to manage some hardware. It is not signed so GateKeeper will prevent you from running it until you go to security preference and allow downloads from anywhere to run.

I'll probably set up syslogd forwarding so I don't need to fire up a Lion VM or boot back into Lion for routine diagnostics.

This is a bit of a pain to not be able to do some of the following things with a supported client on Mountain Lion:

  • save and manage profiles
  • see signal strength graphs
  • configure syslog forwarding
  • look at the system logs

This seems like a poor solution since the newer AirPort extremes are not usable even on 5.6 version of the software and I strongly dislike using unsupported software to manage something like a network router.


Here's how I did it. Worked fine for me:

  1. Find Airport Utility 5.6 on a machine running Lion. Copy it directly from the Applications folder onto a formatted thumb drive or the like. (Or extract the app from the .pkg using Pacifist.)

  2. Copy the app to the desktop on your Mountain Lion machine.

  3. Rename it to Airport Utility 5.6.app

  4. Copy it to the Applications folder. The end.

All the problems arise when you try to REPLACE 6.x. So don't replace it... just install them side-by-side.

This way you get the best of both worlds: they both work fine (if you may call anything about 6.x "fine"). Doing it this way does not interfere with updates. And if you need to turn on SNMP just open 6.x and do it. Then close the damned thing and use 5.6 for everything else.

  • This is my preferred way of doing this often when wanting to run multiple versions of the same app. Sometimes it doesn't work of course, thanks for the actual use report! Commented Nov 1, 2013 at 19:24



It works amazingly!

  • 1
    Welcome to Ask Different! Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. Please take a look at the FAQs for more info.
    – gentmatt
    Commented Sep 27, 2012 at 13:00

Airport Utility v5.53 works fine in 10.8

  • Sorry, but same error - you have to go part way through the install before it complains, but when you choose an installation disk it errors. Also, it's not signed, and Gatekeeper doesn't want to allow it, which made me laugh :)
    – stuffe
    Commented Jul 27, 2012 at 22:51
  • I tried the installers that are available from Apple from 5.3.2 and up - they all decline to install on to Mountain Lion.
    – bmike
    Commented Jul 27, 2012 at 23:09
  • That's a bummer, I'm glad I've already installed 5.6 a few months ago.
    – nohillside
    Commented Jul 28, 2012 at 19:50
  • It's even more than just a bummer, @patrix, as older AirPort Express devices don't work with 1.6. I guess the OP should report a bug. (I'm glad I installed 5.6 earlier too.)
    – Arjan
    Commented Jul 29, 2012 at 15:24

After I tried every other solution offered out there, this one finally worked for me: Download Pacifist for Mac. OPEN the package in Pacifist then EXTRACT it to your Applications folder. Then dig down the files until you find the application. Open it and you're good to go.

  • 1
    Welcome to Ask Different! Answers aren't sorted in any special way usually so it's kind of difficult to understand which package you are referring to here. Also I wouldn't be surprised if not everybody knows what Pacifist is and where to get it from. By adding this you would make your answer more useful for everybody.
    – nohillside
    Commented Mar 4, 2013 at 6:23

The above will not work with the new Apple Extreme 802.11ac Router & Time Capsule. Apple has decided to eliminate SNMP in the firmware.

  • Could you elaborate on what specifically above will not work. Answers can be sorted by votes, time and newness, so there's no set order.
    – bmike
    Commented Jul 1, 2013 at 2:55
  • Airport 5.6 will not allow you to turn on SNMP in the new Apple Extreme 802.11ac Router & Time Capsule. I am using iNet and am unable to see the traffic bandwidth since I cannot turn on SNMP. Any workarounds for the 802.11ac version?
    – Kent
    Commented Jul 1, 2013 at 21:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .