Most of my applications crash whenever a sound is played -- but not if the machine has been recently rebooted.

For example, Mail.app crashes when I send email, because of the whoosh sending sound. Safari/Chrome/Firefox will crash when Flash plays sounds, e.g. with YouTube, but does not crash for silent Flash apps. iChat will crash if I get a video chat request. iTunes will not start at all.

All display the same symptom -- freeze with spinning beach ball. All can be force-quit without issue, and without affecting other applications.

If I start an app right after a reboot, it generally will run just fine. If I open Safari after a fresh reboot, I can watch Flash video for an hour or two without issue, but the next morning, it will crash again.

If I open Skype after a fresh reboot, it will remain open and working, sometimes for days. But if I close it, it will not open again until I reboot.

I've go through flashing PRAM and repair permissions with the Apple techs, and it doesn't seem to help. Any idea what I might be able to to do to get sound working again? I've been told to reinstall, but I primarily use the machine for work, and I can't take a week to get everything configured again just so I can use iTunes and YouTube.

What is particularly annoying is having to quit Mail.app and restart after each sent email. If there were a way to disable the sent email sound that would be great too.


Cross-posted: http://discussions.apple.com/message.jspa?messageID=12791456

4 Answers 4


Can you open the Console application (in the /Applications/Utilities/ folder) and see if anything is reported up to and during the application hangs?

Are you actually getting a crash or just a hang? (A crash will display an "unexpectedly quit" dialog on its own (creating a .crash file) , whereas a hang will require you to explicitly force the application that's not responding to quit, which will then generate a .hang (" stopped working because of a problem).

If you are actually getting a crash, please post the crash log (as much as you can) or otherwise provide access to it (as they can be somewhat long). If it's a hang, perhaps any output to Console might be more informative than the .hang report.

You mention iTunes does not start at all: do you mean it immediately starts to hang when you try to launch it, or does it crash with an unexpectedly quit dialog?

Also, try launching Activity Monitor (also in /Applications/Utilities/) and be sure to set the "Show" popup menu to All Processes. Check once at launch or on a fresh startup to see if there are any processes highlighted in red. Then when you begin having the problems, check again in Activity Monitor to see if there are any processes shown as not responding; if so, please post the name of them along with any info that's reported to Console.

My rough guess of what's happening is that either coreaudiod itself, or another sound/multi-media-related framework or launch-on-demand agent or service that these apps need is not responding, which in turn causes any applications that rely on it to hang as well.

  • Thanks so much, NSGod! Your advice to look at the console (duhhh!) led me to finding the error message re: Adobe Version Cue, which led me to the solution (uninstall version cue)
    – mrjf
    Commented Jan 2, 2011 at 4:20

NSGod's advice to look in the Console led me to a whole bunch of errors like this one:

1/1/11 8:03:31 PM   com.apple.launchd.peruser.501[288]  (0x1002002f0.mach_init.VersionCueCS3monitor[20180]) The following job tried to hijack the service "ah_serv_trigger.v1:20179" from this job: 0x103ae66a0.anonymous.Google Chrome He

From there, I found someone else complaining about the same problem who fixed it by removing Adobe Version Cue CS3.

I uninstalled Version Cue using these instructions. I had a different set of files to remove — not all the ones they listed existed on my Mac, and not all of my related files were on that list.

I used these commands:

sudo rm -rf /Library/PreferencePanes/VersionCueCS3.prefPane/
sudo rm -rf /Library/Preferences/com.adobe.versioncueCS3.plist
sudo rm /private/etc/mach_init_per_user.d/com.adobe.versioncueCS3.monitor.plist
sudo rm /Library/LaunchDaemons/com.adobe.versioncueCS3.plist

Without even rebooting, all my audio problems vanished.

Thanks so much to everyone who gave advice, especially NSGod. Sorry I cannot give upvotes, or hyperlink my links, but I lack the points to do so. Once I have them, I'll come back and upvote.

UPDATE: Don't do this one, that I earlier had in the list:

sudo rm -rf /Library/Application\ Support/Adobe/Adobe\ Version\ Cue\ CS3/

Seems that that one prevented Photoshop from opening some files. I restored it, and Photoshop works fine, and so does audio.

  • 1
    I've done the hyperlinking for you (hope that was okay). And even before you have sufficient rep to upvote you should still be able to accept an answer, so please consider doing so.
    – Dori
    Commented Jan 2, 2011 at 7:02
  • Thanks Dori! I appreciate the linking. I'm getting the message "You can accept your own answer in 41 minutes". I think the answer I gave is probably the most useful to future folks with this issue (although NSGod's answer gave me the clue for where to start looking), so I think I'll wait the 4 hours (now 41 minutes) and come back and choose that as the answer.
    – mrjf
    Commented Jan 2, 2011 at 7:51

It is difficult to say what the problem is. It sounds like you have a done a good job isolating the problem as related to audio. Here are some general things that might help.

  1. Genius Bar - Often problems such as this are caused by hardware issues. If it is a standard Mac system, it likely isn't a hardware compatibility or driver issue as is common with Windows. There is a small chance that it is a known hardware problem in which case I would suggest visiting a Genius Bar if you are near an Apple Store. Even if it isn't a known problem, they will likely be able to determine if it is a hardware issue or not.

  2. Reinstall Mac OS X - If it is not a hardware problem, then it must be something about the operating system, software or configuration that is causing the problem. Unfortunately, with computer systems the easiest answer is to get the system back to a known good state. Generally this means reinstalling the system as has been suggested to you.

  3. Restore from Time Machine - If this problem is relatively new and you have a Time Machine or Time Capsule, you could try to get your system back to a known good state by restoring to a time when you did not have this problem.

  4. Back Track - Try to determine what applications or changes you have made to the system that may have caused this problem. Try to undo those changes or uninstall those applications as much as possible. If you have a similar known good system, you can try and compare the audio settings between the machines and look for any differences. Eliminating potential causes and comparing to a known good configuration are two common troubleshooting techniques -- unfortunately, this could require some technical expertise as well as be time consuming.

  5. Disable Sounds - If you want to just minimise the damage, try disabling as much of the sound effects as possible. Look both in the system preferences and in individual application preferences. For example in Mail, there is a tick box in the Preferences for 'Play sounds for other mail actions'.

One last thought, since everything seems to work fine after a fresh reboot, could it a be a problem caused after waking from sleep or hibernate?


Sounds like (no pun intended) you've got some corrupt files on your hard disk, in particular CoreAudio libraries. You may have a dying heard disk.

I would suggest at a minimum backing up your home directory and reinstalling.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .