I had a Smart Search for my Photo Stream files located at ~/Library/Application Support/iLifeAssetManagement/assets/sub/, searching for JPG and PNG files. I found that not all files were showing up. So I went looking for them myself and was able to locate them.

enter image description here

How does this make sense? Why doesn't finder see the same results? The list of files was achieved using the find command at the prompt. I then passed a simple find result to wc to get the count, 153 files found via find in Terminal but only 75 in Finder using Spotlight? What's the deal?

  • Have you excluded some folders from spotlight indexing? That might explain it.
    – Richard
    Commented Jul 23, 2012 at 14:31

5 Answers 5


It might be necessary to rebuild the Spotlight database by running

sudo mdutil -E /

and waiting a few hours. I had the same issue in the past and rebuilding the index resolved it.

  • 1
    Spotlight does index files located in System folders, but normally leaves them out of search results.
    – l'L'l
    Commented Jul 23, 2012 at 14:39
  • Rebuilding the index using sudo mdutil -E / fixed the issue. Thanks! Commented Jul 24, 2012 at 20:15

I have this all the time...

Manual search or saved search shows:

  • IMG_4668.JPG
  • IMG_4663.JPG
  • IMG_4662.JPG
  • IMG_4661.JPG

and in the /assets/sub folder I see all the files. (including IMG_4664/5/6/7.JPG etc)

After running the following command everything is fine but it will take only a week or so before it's messed up again.

sudo mdutil -E /

Same applies to the ~/Library/Mobile Documents/ folder. Multiple tests on other folders are succesfull. Just not the results for these 2 folders that both happen (?) to be under ~/Library/

Old Macbook and my new (freshly installed) Macbook: same issue


I'm not exactly clear on what you mean by "Smart Search". I'm assuming you're referring to a "Smart Folder", which allows you to specify and save Spotlight search criteria?

In Lion a Smart Folder with saved Spotlight criteria will show up in Finder as a folder with a gear icon. Smart Folders show up in ~/Library/Saved Searches/ with an extension of .savedSearch, which are actually preference lists holding aliases that create a virtual folder.

Looking at your screen capture it doesn't appear you're using a Smart Folder. Another observation is that your Finder search shows the files in the sub directory, where in Terminal you are drilling further down. Since it appears to be a standard Spotlight search it makes perfect sense why you're not seeing the same results in Finder and Terminal.

By default Spotlight does not index or search System folders, which includes the Library folder that you're searching. To resolve the inconsistency here's what you need to do:

In Finder navigate to:

  1. ~/Library/Application Support/iLifeAssetManagement/assets/sub/
  2. In the sub window click inside the search box and hit option return
  3. Search: This Mac | sub should appear just below
  4. Click sub and then + on the right side
  5. From the dropdown menu that appears select Kind is Image All
  6. Click the save button on the right and name it.

If you still aren't getting the same search results vs. Terminal then look through the search criteria options (+) to make adjustments. Hopefully this helped you, and/or anyone else that needs to setup a "smart search".

  • Yes, sorry I meant Smart Folder. I had removed and re-created it multiple times while troubleshooting which is why you do not see it in this shot. Commented Jul 24, 2012 at 20:10
  • Regarding the search location, there was no difference, if I ran pwd on that prompt in Terminal you would see I was in the sub folder, pretty sure @patrix is correct about the cacheing. Commented Jul 24, 2012 at 20:14

This is what worked for me:

Go into System Preferences > Spotlight "Privacy" tab. Press the "+" button at the bottom and add the volume you are trying to search. This will remove the volume from search results. Then click the "-" button to remove the volume you just added. This will reindex the volume that is having problems.

Try your search again. If you're in the same situation I was in, this should work.


I have been searching long and hard to fix the same issue with Finder showing no results when doing a simple search. I came across this solution that seem to have worked effectively and have now cured my aging frustration. I am using OS X Yosemite and from my research it seems multiple OS X releases and a large number of people were having this exact issue.

The solution is below:-

  1. Open a new Finder window
  2. Navigate to your "Library" folder
    • How: Command-Shift-L or in Go menu, choose Library.
  3. Open the "Preferences" folder
  4. Locate the "com.apple.finder.plist" file and move it to Trash (i.e. delete it)
  5. From the Apple menu in top left corner, select Log Out (Or do a Restart)
  6. Log back in to your user account
  7. Open a new finder window and perform another search to test if fixed
  8. Once Finder search is confirmed working again with results showing up, you can then empty the Trash

This should resolve your issues. Good Luck!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .