2

I have a Company name in my Address Book with an e-mail address assigned to it.

The name is Blast Corporation and I want to enter that into the "TO" field in Mail.

Even though Address Book clearly shows it, it does not appear as a suggested address in Mail.app

How can I fix this?

This is in OS X Lion.

1 Answer 1

0

Which field is the name "Blast Corporation" in your address book? Supposedly by default Mail only auto-completes addresses that have been used before through Mail. I'm not sure if that is exactly true though, since I just now setup a contact in my address book which I've never used in mail and it auto-completed the company name. It's possible that you need to check a few settings in Mail.app preferences:

mail.app auto-complete enter image description here


Here's another example of a company in my address book, which auto-completes in Mail.app

enter image description here

5
  • How did you get the suggestion in Mail.app? By typing sales or ACME? Mail.app doesn't complete addresses for me with company names even with the default "complete addresses" option set
    – ephsmith
    Jul 22, 2012 at 20:36
  • @ephsmith, yes I simply started typing 'ACME..' and it auto-completed. Do you have the name in the main title of address book like mine is showing?
    – l'L'l
    Jul 22, 2012 at 20:49
  • Yes, but mine is actually in the company name field. The card is marked as a company.
    – ephsmith
    Jul 22, 2012 at 21:30
  • @ephsmith, very strange — I did mine like you say and it works just fine (see added screen capture).
    – l'L'l
    Jul 22, 2012 at 23:06
  • It is strange. That's why I asked. I only have a few companies that I email and I've had to use nicknames to get completion for a while. I never had to check the "complete addresses" box because it was that way by default. Nevertheless, no completion on company names for iCloud contacts.
    – ephsmith
    Jul 23, 2012 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .