I've been tinkering with my router and have flashed it to use DD-WRT (a Linux distro that can provide me with some extra functionality). This in turn has allowed me to create a Samba server to share the USB drive connected to my router.

It appears to be working fine and I can connect to it, modify files etc. from my Windows 7 box. But I'm having trouble connecting from my MacBook (running Snow Leopard). What I'm doing is:

  1. Switching to Finder
  2. Hitting Command + K to bring up the "Connect To Server" dialog
  3. From here I try to connect to "smb://[email protected]/public". being the router, share being the username and public the folder I wish to access.
  4. This then provides me with a username & password box, with share populated in the username field. I enter the password for the share account but it tells me it's invalid. I've also tried different username/passwords just incase and using guest access. All no good.

Does anyone have any ideas on what else I can try? I'm definitely getting the right username & password combination.

Cheers for any help Lee

2 Answers 2


I finally found the answer on the DD-WRT forums and it's annoyingly simple but I would never have guessed it in a million years.

The username has to be entered in UPPER CASE. So while smb://[email protected]/public didn't work, smb://[email protected]/public did!

Just wish I hadn't spent a day trying to get find that out!

  • 2
    I have reason to believe that once a username+password has been entered, the kernel is caching that particular combination until the computer is restarted. If the password was incorrect, you have to change some character in the username to upper-case in order to try a different password. Since the username is lowercased by Samba anyways, it "works". I've tried all combinations of deleting keychain entries, killing Finder, etc, and the only workarounds for this problem was to either tweak the username, restart the computer, or use the correct password at the first try. Jan 1 at 10:51
  • Holmes, you've cracked the case! Mar 17 at 0:29

Good find! I expect it is because Linux works on case-sensitive file systems. Macs mostly do not anymore, although they can be configured to respect case. If the uppercase annoys you, you can either check the share to make sure it's lowercase, or check your /etc/smb.conf file on the DD-WRT to make sure it respects case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .