It looks like Apple may have changed something since I last configured this...

Some time ago (maybe two years?), I bought an Airport Extreme and plugged an external hard drive into it. From my laptop it was simple to configure Time Machine to use that shared disk as the storage. It created a sparesebundle and it's been happily backing up ever since.

Now I have a new disk to use. So I removed the old one and installed the new one and prepared for that initial very large backup over the network. However, it would appear that there's no option to use this shared disk for backup purposes.

When I enter Time Machine preferences and opt to select a disk, there are no disks listed:

enter image description here

Even though there are actually two network drives (and the local drive) mounted:

enter image description here

In this case, "Backup" is the drive shared from the Airport Extreme.

If I opt to "Set Up Other Time Capsule" it takes me to the Airport Utility (6.1) in which I find no options mentioning any kind of Time Capsule setup. It lets me share or un-share the disk, that's about all I can find.

I also tried downloading Airport Utility 5.6 to see if the older interface had some familiarity for me to set up the disk for Time Machine, but again all I seem to be able to do is share or un-share it. I can't seem to tweak anything that would result in the Time Machine Preferences actually seeing the target disk.

Has anybody run into this issue before? Is there something simple that I'm overlooking? The driving factor in getting a new disk was to increase the size so that I could use the same disk for automated backups from my Linux box (which would mount the share and run some simple cron jobs using tar for incremental backups), which mounts the share just fine (the last mount point in the list):

enter image description here

Ultimately, how can I use a disk shared from my Airport Extreme as a storage target for Time Machine in OS X 10.7?

Edit: To add some clarity, the hard drive in question was formatted on my Mac. It was given a single partition and formatted as "Mac OS Extended (Journaled)" and is 3 TB in capacity.

I've searched around on the internet and people who are experiencing the same symptoms all seem to be using some off-the-shelf NAS. The general theme is that the firmware for each such NAS needs to be upgraded to support updated protocols. However, the controlling device in this case is an Airport Extreme which, to my knowledge, is fully up to date. So I can't imagine why anything would be unsupported in this case.

I was previously using the same setup with just a different external hard drive. That worked fine. Time Machine could mount the drive and perform the backups all by itself. All I did was swap out the drive with a new one, and now Time Machine can't use it.

I've also just noticed that when Time Machine tries to start a backup, the "Name" of the target device get appended with a number. It started with "-1" and then I tried to de-select and re-select the target disk, not it has a "-2":

enter image description here

Update: Just to test, I've removed the drive from the Airport Extreme and plugged it directly into my MacBook Pro, and it's currently in the process of backing up without problem. I'll try re-adding it to the Airport Extreme after and see if perhaps it can back up (maybe the problem was in the creation of the sparsebundle on the file system? it's worth testing).

3 Answers 3


Try using the following Terminal command then restarting System Preferences (if it's open):

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1
  • 1
    Definitely a step in the right direction. This allows me to select the disk. However, when I try to initiate a backup I receive an error: The network backup disk does not support the required AFP features. This has at least given me more to Google, though.
    – David
    Commented Jul 21, 2012 at 19:51
  • 1
    The missing AFP feature is most probably the ability to create hard links to directories. There are ways to put a correctly formatted disk image onto the shared drive, Google will give some pointers. But as in all these cases: Do you really want to entrust your data/backup into such an unsupported setup?
    – nohillside
    Commented Jul 21, 2012 at 19:58
  • Interestingly enough, I'm finding a lot of search results for this error message indicating the users are trying to use various commercial NAS devices, and to do so the vendors would need to upgrade the firmware. However, I'm using an Airport Extreme, which is Apple's own product. I would think it would be supported, but so far no luck.
    – David
    Commented Jul 21, 2012 at 19:59
  • 1
    @patrix: But why is it an unsupported setup? It's an Apple-formatted disk on an Apple-formatted device. It seems a bit silly to be "such an unsupported setup." If this is the case, then I guess the real question is: Do I really want to entrust my data/backup into a setup which can so easily become unsupported?
    – David
    Commented Jul 21, 2012 at 20:00
  • The defaults command already enables an unsupported feature, adding the disk image would be even more risky. How did you initially format the new external disk? Maybe it's enough to plug it directly into the Mac, format it with Disk Utility and connect it to the APE again.
    – nohillside
    Commented Jul 21, 2012 at 20:06

I knew it was going to end up being something simple that I was just overlooking...

As I Googled around more, some of the information I found contained images of the icons for the mounted drives. This turned out to be my biggest clue. Notice the drive as I had mounted it:

enter image description here

As it turns out, this is mounted and an SMB share. Easy enough to overlook, since all of my other network stuff is SMB. (I mainly use my Linux server for central file storage and share it with Mac and Windows clients, so SMB is the most universal.) However, Time Machine doesn't like SMB. I must have not even paid attention to the difference years ago when I first set it up. But by mounting it as an AFP share:

enter image description here

I was able to see it in Time Machine (even after reverting to show only supported targets) and am currently backing up to it.


I know it's a really old question, but there are some that still use Airport Extremes for Time machine and they may face the same issue as I did today. Mac osx 10.14.5 and Airport Utility 6.3.9.

I changed the airport-time machine drive today and I had the identical issue as the OP.

But for me the issue was because the Shared Disk was secured by password, so it was unaccessible by Time machine app. All I had to do was to go in Finder, Connect to the Airport base and unlock the HDD (a popup asking me for password was prompted).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .