Disk utility reports that the disk needs to be repaired.

I can't find the original boot disk, so I booted to single user mode and ran:

fsck -fy

This reported that it fixed a problem, and that the disk had been modified. Re-running it a 2nd time said that it was OK.

So I restarted, and tried running the Disk Utility app again - and it still reports that the disk needs to be repaired.

Repeat, with the same results - fsck says it has repaired the volume, but the Disk Utility says there are problems.

I also tried running diskutil repairVolume but it would not run because I was in single user mode.

Is there anything else I can try to repair the volume? Is there a way to create a bootable DVD/USB from a running system so I can try running the Disk Utility app?

  • Can you copy and paste the Disk Utility log file contents into your question? You can view the log file by pressing Command + L while in Disk Utility.
    – Matt
    Commented Jul 19, 2012 at 6:48

2 Answers 2


Honestly, you don't mess around with these messages. I think that the first thing to do is to make sure you have a complete backup of your hard drive. Get a second drive with enough capacity. Use Carbon Copy Cloner or Time Machine, or Super Duper to copy the drive.

Once you have a backup, you could easily reformat the drive, (this will avoid bad sectors), and then copy back from the backup.

My 2¢ Hope this helps..


This answer pertains to your bootable DVD/USB question.

If you are using Snow Leopard, you'll need the Snow Leopard install DVD, which will allow you to run Disk Utility (you'll find it in the Utilities menu). In order to boot from DVD, hold C during boot (after the startup chime but before the Apple logo appears).

If you are using Lion, you can create a bootable Lion DVD or USB key from a running system by following these instructions from Lifehacker. You can then run Disk Utility from there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .