I have a late 2011 macbook pro. I decided to upgrade to SSD. Here are the steps I took:

  1. Connected SSD via USB
  2. Formatted using MAC OS Extended Journaled (using disk utility)
  3. Cloned HDD to SSD using Carbon Copy Cloner (during this clone, I was prompted to create a recover partition which I did)

I then rebooted (holding CMD + R) to select my new SSD as the boot up drive. This worked fine. To test this fully I created some files on the desktop and restarted several times switching between SSD and HDD to verify that I was actually booting up into SSD.

I can boot up via SSD with the HDD in the MBP and SSD connected via USB. But when I remove the replace the HDD with my SSD and power it on, all I see is the apple logo and the spinning wheel forever. For some reason, I cannot boot up when it has been fitted inside.

Any ideas why this may be?


Further on from this, I can't boot into the recovery partition and I have also cloned the them switched around (SSD internal, HDD on USB). This cloned fine but still presented me with the same problems. Attached is the CMD+V output from booting up with SSD inside.

cmd_v output

  • Press and hold <kbd>Command</kbd> + <kbd>V</kbd> while you start up your computer until you see the verbose screen (lots of white text on a black background). If you see any errors happening there, can you post them in your question?
    – Matt
    Commented Jul 18, 2012 at 13:50

6 Answers 6


Thank you for all the responses. I believe I have tried everything and have lost count of how many time I have switched the drives, formatted and reinstalled the Lion.

I figured out the problem, in the end, it turned out to be a problem with the firmware. The firmware on the drive was not compatible with late 2011 MBP and needed to be downgraded. After downgrading the firmware to 0309 it worked like a treat!

Thank you for all the responses, most appreciated. I hope this helps some people out.


I know it might sound simple, but have you tried holding down Option while booting and seeing if the drive is visible to boot from. If so, select it.

If you tell the Mac to boot from a drive that is on a certain port or connected a certain way, and then move it to a different port or connection type, i.e. from USB to SATA in your case, the computer itself won't know that you made the move. It will look for the USB drive that is was booting off of because that is where you said to look.

I had a similar issue when it came to booting off my new SSD in my MacBook Pro. I told it to boot off my SSD when it was in a original HD SATA Port and then moved it to the place where the optical drive was using an OptiBay, putting the old HD back in its original bay so that I have two HDs. It booted up and spun for about 30 seconds, way too long for an SSD, and then found the old drive that I still had in the original HD bay, it never found the SSD because it wasn't where I had told it it was, so it then went and looked for things it could boot off and found the old HD before the new SSD.

Try holding the Option key while booting and see if you can find your HD and boot from it, once you do, set it as the default boot drive in your system preferences so that it knows that its supposed to boot off of it.

I hope that this helps.

  • Thanks for the reply. I've shutdown the mac, inserted the SSD, then booted it up whilst holding down the option key. It can see it (it shows me a recovery hd and my SSD). After I click it and press enter, it gives me the apple logo and spinning wheel. It's been on this for 5 minutes so far so I am assuming that it hasn't worked?
    – Nadine
    Commented Jul 18, 2012 at 16:58
  • It's really weird. Because when it is fitted interally, pressing option whilst booting up establishes to me that it is connected and the mac can see it. It just fails to boot from it :/
    – Nadine
    Commented Jul 18, 2012 at 16:58
  • It might be an issue with the installation of the OS when you copied it over to the new drive. Can you boot from the Recovery Partition. If so, you might need to reinstall the OS on the SSD. This won't wipe anything out, it will just install the files needed for the OS and update/fix them if they are corrupted. If all else fails, an erase and install should work, but use that as a last resort. If you can boot into the recovery partition, then the drive is fine, the OS might have just gotten corrupt and needs to be reinstalled.
    – de_an777
    Commented Jul 18, 2012 at 17:34
  • Nope, I can see the recovery partition but everytime I try to boot from it, I just get left hanging ont he apple loading screen. I'm about to attach the verbose screen from booting up with SSD inside. I can't see anything obvious but could you have a look?
    – Nadine
    Commented Jul 19, 2012 at 5:46
  • Did you ever get a chance to try and reinstall the OS on the drive? That is going to be the easiest thing to try first. It won't delete any or your files, just upgrade and fix corrupted ones. Make sure you still have your back up/drive you cloned from just in case something happens. After you try this, let me know what happens, ok? If you need help making a bootable usb stick install drive for Lion, here is a link on how to make one: macrumors.com/2011/08/08/…
    – de_an777
    Commented Jul 19, 2012 at 13:57

I had this issue also but discovered that Carbon Cloner gives boot priority to the Connection used to clone the drive i.e. USB. (If You Clone the drive via usb it will only boot via usb)

So I removed the main drive, inserted the drive I wanted to clone into the main slot, and cloned the old drive by connecting it to USB with the new drive in the main terminal. This worked perfectly and I have no issues with the cloned SSD not booting.

Hope This Helps!


I'm battling the same problem with my Mid 2007 (7.1) iMac running Snow Leopard. Cloned new 2 tb Seagate SATA drive in a external USB enclosure, removed 300gb Hitachi Deskstar internal drive (probably not the original) and installed the "booting when USB" Seagate in the internal mounting. Will not boot either drive, new Seagate as internal and won't boot the previously internal Hitachi in the USB enclosure. Only get the Apple logo and the spinning "wait" progress icon. Holding the option key does nothing at all, cannot boot into Open Firmware, cannot boot into safe mode with the shift key. I decided to order a new Snow Leopard CD/DVD and will install the OS from that onto the new drive in the internal position.

  • @Tetsujin Actually I see this as an answer and not that bad of one either. It explains that the same issue is common to other hardware and proposes a solution of getting a CD to install the clean OS from a bootable CD
    – bmike
    Commented Aug 11, 2015 at 13:04
  • @Tetsujin I try to look at posts that have good technical details and more than three sentences long in the best possible light. Your flags that I've handled today has e all been high-quality and much appreciated
    – bmike
    Commented Aug 11, 2015 at 13:38

If you cloned the drives, the content and name is the same. Try changing the name for the SSD to make sure the computer isn't changing to the HDD after unsuccessful booting from SSD via USB.

Try booting from your HDD via USB while the SSD is connected internally to the MBP and clone the drives again to be sure the SSD works correctly while connected to the MBP directly.

  • Thanks for the reply. How do you mean "try changing the same for the SSD"? When I formatted the SSD drive I renamed this to "SSD". Do I need to do this again?
    – Nadine
    Commented Jul 18, 2012 at 17:01
  • I've restarted the copying processed based on your advice of swapping the disks around (SSD connected internally with HDD via USB). The disk utility tool could see it and erase it fine but the recovery tool (to create a recovery partition) is struggling to complete. Kicked off this process about 30 minutes ago and it is still stuck on "checking catalog file". Faulty SSD?
    – Nadine
    Commented Jul 18, 2012 at 17:49
  • I've cloned from the USB HDD to internal SSD and the same problem still exists :( It can copy fine, but cannot boot :(
    – Nadine
    Commented Jul 19, 2012 at 5:45
  • After cloning did you go to System Preferences > Startup Disk and select your SSD to be the drive you're going to boot from?
    – user22594
    Commented Jul 19, 2012 at 17:23
  • Also worth a try is to install a brand new OS X on the SSD which is installed internally to see if there is any hardware incompatibility. After booting from DVD use Disk Utility to partition your SSD and choose Options > GUID Partition Table to make it bootable on Intel Macs. You can choose whatever number of volumes you want to have. Then install OS X.
    – user22594
    Commented Jul 19, 2012 at 17:31

I have done something very similar recently. Although I was using spinning disks and not SSD. But for you it sounds like your SSD is working fine because it is working when it is on the outside of the computer.

If the above options aren't working with your set up I would suggest trying "SuperDuper" as your cloning tool. It worked great for me recently to move up disk sizes. The procedure I followed was exactly as you describe.

  1. Started with a Moutain Lion laptop.
  2. Connected new (larger) disk to USB port on computer
  3. Ran SuperDuper to clone the internal laptop hard disk to the new larger disk
  4. Went to bed whilst disk clone ran
  5. Booted off external disk by restarting and holding down option
  6. Put external large disk into inside of MacBook
  7. Rebooted, held down option and booted off the new disk.

Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .