Along with myself, a couple other people in my office are having the same issue as I. Below, I will go through all the steps I've taken thus far (it's been a long time) and the results if I have them/can remember them.

Issue: When connecting to any server (smb, vnc, doesn't matter) the connection never initializes. It stays at the "Connecting to '...'" window. I can leave it up all day and it won't complete nor will it error out.

Current workaround: Create a new profile on the computer, and either User Switch or Migrate to that user.

Troubleshooting steps taken:

  1. Ping. I can ping all and any servers fine. It returns with reasonable times, and resolves the host fine. If it's a webserver, I can go to it from any browser no problem.

  2. Log. I can't find anything relating to when I first attempt connection, or anything during the duration of the attempt. Checked all logs that seemed relevant, and got nothing.

  3. Netstat. Routing tables match the new user account fine.

  4. sysctl.conf. Added the following:


    Rebooted, still nothing.

  5. Reset PRAM. Nope.

  6. Reset SMC. Nope.

  7. Connect to server on new account, then try to access it on the broken one. Drops connection to the server and dissapears from finder.

  8. Delete Finder.plist. Didn't help.

  9. Disable local firewall. Nope.

  10. Connect using static IP and DNS name. Nope.

I've probably tried more along the way, but have forgotten.

  • 1
    The fact that it's happening to coworkers as well suggests an issue with the network or the servers you're trying to connect to. – robmathers Jul 17 '12 at 3:32
  • That's what I thought as well, but it's a minority of people in the office. 3/500. It only happens in our team using macs, so about 3/30. Also because creating a new account on the computer fixes it, I believe it's tied to the computer, not the network. – Mike Jul 30 '12 at 16:29
  • I don't know that this is a definitive fix, but I've seen this problem on occasion when a machine lost connection to the server for some reason, but the server hadn't cancelled their session. Opening the share manager on the server and manually killing their session seemed to resolve the issue. Note: I've only seen this problem two or three times, and not nearly as regularly as what you are describing. – RESPAWN Jul 31 '12 at 18:59

Try this: rm ~/Library/Preferences/.GlobalPreferences.plist

It's an invisible preference

  • 1
    Interesting, didn't know about that one. But what makes you think that this will solve the problem? – nohillside Aug 3 '12 at 8:47
  • that invisible file can get corrupted when connecting to a server. I am a sys admin and had 5 users all have this problem crop up in a week. This fixed it on every one. Clue was when you said you can connect with a different user account. Clearly the other account had clear GlobalPreferences file – Doug Aug 3 '12 at 18:13
  • This worked! Thank you! You have become a hero here at the office. My gratitude has been extended. – Mike Aug 13 '12 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .