In my iPhone settings where I'm supposed to turn Wi-Fi on or off, it is just grey & says 'No Wi-Fi'.

I have reset network settings, restored phone, re-synced everything, but still have this problem. Does anyone know how to fix this?

12 Answers 12


Same issue - a perfectly good, 7 month old i4S that is out of Apple warranty (original phone got wet, I went to Apple Store and bought a $199 replacement phone but they only provide a 90 day warranty of that vs. 1 year on a 'new' phone from a cell carrier - go figure).

Apple hosted 2 chat support sessions and 1 store visit, at which time they said it's a hardware issue, out of warranty, buy a new phone & good luck. So I am going to buy a new phone - but it won't be an iPhone!

So - in summary, your issue is likely a hardware issue and you might want to learn from someone who regrets paying for a "repair" rather than just buying a new device or other warranty extension.

  • ...this is all after an iOS7 upgrade...wifi grayed out.... – MaZ Nov 6 '13 at 20:51

See this Apple support page: http://support.apple.com/kb/TS1559

This also is typical of hardware problems relating to wifi chip or an internal antenna connector failure, either of which indicates that a trip to a Genius Bar may be in order. Apple service also is available at https://locate.apple.com

  • 1
    I just called Apple Care & they will fix my phone under warranty or replace it with a new one. – Lisa Jul 16 '12 at 4:43

I had the exact same problem. But I went to Apple and they replaced. So go to Apple and they'll hopefully replace it for you too (if you have AppleCare).


I have been bitten by this - the symptoms were that the 'enable wifi' slider button was completely grayed out after multiple reboots, backup/restores, and updates.

The 4S has a well-documented issue with overheating that apple refuses to acknowledge or fix. To see if your phone is affected by this, power it down, wrap it in a paper towel, and (seriously) place it in your freezer for 20-30 minutes. Power it back up, and try to turn on your wifi. It might work anywhere from 20 minutes to an hour.

The bad news is that if you are indeed affected by this issue, you'll need to have apple replace the phone.

  • 3
    I cannot recommend strongly enough that you do not put your iPhone into the freezer. If it is a hardware issue, you could be causing further damage that would allow them to disclaim responsibility for fixing it. – tubedogg Sep 12 '13 at 14:46
  • Same bug. Noticed it in association with some trouble booting up. Slider won't allow WiFi on. Would Apple replace a 2 year old iPhone 4s, or will they patch a bug soon? I didn't notice any significant heat problems myself. – kal-al Sep 23 '13 at 23:40
  • I've heard that putting it in the fridge and then resetting network settings provides a temporary fix, I may try that. But maybe fridge not freezer? – kal-al Sep 23 '13 at 23:57
  • Putting it in freezer inside a plastic bag worked for me but only for 20 minutes. I moved to Google Nexus 4. – Bharat Patil Nov 16 '13 at 16:44

I had the same problem. It took several tries but this is what worked (kinda) for me:

  1. Cool off the iPhone. 15 minutes in a fridge. Temperature seems to have a role.
  2. Reset Network Settings (General > Reset > Reset Network Settings).
  3. Let it reboot, and give it time if it's stutter-y after a boot.
  4. It should allow you to have WiFi enabled. Connect to your WiFi network.

So this got WiFi to be enabled for me, but I'm experiencing trouble where it keeps dropping the WiFi signal and trying to reconnect. Associated with this I'm seeing the iPhone occasionally freeze when trying to deal with the WiFi settings, sometimes when that's frozen Control Panel doesn't work to turn Airplane Mode on even, stuff like that.

Unfortunately it is impossible to downgrade to iOS 6.1.3 now. Either the iPhones will get better themselves like they were before the problems hit, or Apple will put out an update soon, or it is a possibility that our iPhones will need to be replaced.


Wi-Fi greyed out in iOS 7 iPhone 4 or iPhone 4s is a hardware issue and you need professional help.

podmod.de fixes the issue for €69 in 20 minutes. Check the website and get it repaired.


This is a very complicated issue of iPhone you're facing. I hope till now you've discovered a solution for this issue, if not than I want you to say after upgrading to latest iOS 7 many iPhone users around the world faced similar problem, and than a later version Apple released including WiFi bug fix and the latest upgrade fixes such problem upon installing. Thus if you're having such problem after an upgrade consider installing latest iOS upgrade or older version to have back your WiFi.


I had the exact same issue with a 2 year old iPhone. I read up on it all day and tried everything. Last ditch - I tried a weird solution I found online and it worked. Overheat the iPhone gently with a hot hair dryer until it gives the Temperature alert and goes into recovery mode.

Now put it in a Ziplock bag and place it in the freezer for 5-10 minutes. If it comes back on you are ready to do the following.

Go to Settings > General > Reset > Reset Network Settings and reset the phone.

This takes a few minutes. Once complete, force reboot the iPhone by holding down the Home and Power buttons simultaneously for about 10 seconds. Once you see the Apple logo let go of the buttons.

It's weird - it was my last roll of the dice - but it worked. I was able to switch on the WiFi and it connected.

There is a Canadian post online where many people have had the same success.


This is a KNOWN issue with a certain batch of 4s's that have wifi chip temp. sensor issues. Warming the wifi chip with a soldering iron for 30 secs or so and then reseting the network settings will get wifi back. Maybe for a month, maybe only a few days. Has worked for me several times.

Some of the information contained in this post requires additional references. Please edit to add citations to reliable sources that support the assertions made here. Unsourced material may be disputed or deleted.


This may just be a temporary glitch.

Try restarting the iPhone:

To restart iPhone, first turn iPhone off by pressing and holding the Sleep/Wake button until a red slider appears. Slide your finger across the slider and iPhone will turn off after a few moments.

Next, turn iPhone on by pressing and holding the Sleep/Wake button until the Apple logo appears.

If that does not help, try a hard reset:

To reset iPhone, press and hold the Sleep/Wake button and the Home button at the same time for at least 10 seconds, until the Apple logo appears.

Reference: iPhone Troubleshooting Assistant

  • Rebooting doesn't help. – kal-al Sep 23 '13 at 23:39

This unfortunately is a widespread issue which has sparked an heated debate on the Apple discussion pages, as you can see when you do a google search on "iphone 4s wifi"

This issue is probably caused due to an unreliable Broadcom wifi chip (which also handles the Bluetooth communications you might have experienced) The iOS seems to overheat the Broadcom chip with as result a possible hardware failure of the chip. Since the chip is part of the mainboard this means your iPhone 4S is now officially dead and you are out of warranty. Also since Apple claims: 'the upgrade to iOS 7 is at your own risk'

Since there are mostlikely thousands of people affected and Apple is keeping a 'deafening silence' a.k.a. not giving any response to all the cries for help I have tried to sum up my observations on this and have set up a page where you can read on this.

  • I'm going to edit out the part of this about "Apple moderating the discussion" as the community moderates this site. – bmike Oct 12 '13 at 23:46

15 minutes in the freezer has worked, do it at your own risk, but I had ice on the screen, but its faster than it ever was and the WIFI is back working

  • Can you provide some research or other information to support your answer? – sameetandpotatoes Dec 6 '13 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .