8

Apple lets users who occasionally want the use of Mouse Keys to enable/disable it by pressing Option () five times. I use Maya, so I'm constantly using the Option key to manipulate the camera, and this usage often triggers Mouse Keys. Unfortunately, this disables the rest of my keyboard (see this Apple KB page) and I can't use other helpful shortcuts. I can of course disable it again, but it's annoying when I have to do it again and again.

I went to the appropriate place in System Preferences to disable this (Universal Access > Mouse & Trackpad), but it's greyed out. I've done extensive searching and haven't found anyone with a similar problem.

Why is this happening, and how can I stop it?

  • I'm currently on a windows computer, and I don't remember the exact path, but could you post the contents of com.apple.keyboard.plist or com.apple.universalaccess.plist (or something similar; see note above)? I believe you will find the files in ~/Library/Preferences/. – Matt Jul 16 '12 at 7:24
  • Rooted around those a bit, here's what I found: com.apple.universalaccess.plist only contained one thing that could possibly be of any use, useMouseKeysShortcutKeys, a Boolean type set to YES. I attempted to disable this, but neither the System Preferences window nor the option key act like this had an effect. Nothing else has any potential at all. – Timothy Mueller-Harder Jul 16 '12 at 11:35
  • Also, I couldn't find the Keyboard plist. I assume it has some sort of alternate name...? – Timothy Mueller-Harder Jul 16 '12 at 11:37
  • I didn't know if it was keyboard or universalaccess. What do you mean by "disable"? Did you set the value to NO, or did you delete the line altogether? – Matt Jul 16 '12 at 11:49
  • I set it to NO. – Timothy Mueller-Harder Jul 16 '12 at 13:13
1

To avoid editing plist or avoid command line, you can still do it in the prefs menu.

Go to System Preferences > Accessibility Preferences > Mouse and Trackpad > Options > Press Option Key five times to toggle Mouse Keys" (1st option). You have to uncheck "Ignore built-in trackpad when Mouse Keys is on", first.

  • Ahh, it was right under my nose the whole time! – Timothy Mueller-Harder Jan 16 '17 at 4:44
  • Thanks!!! Same here. That stuff is really annoying, and if you fall into that trap, you are in real trouble! I did not know that such a thing exists and did a re-install of the os until I found how to disable that... – Christian Tismer Jan 4 '18 at 16:47
  • ouch! well hopefully the reinstall cleaned up a bunch of other things for you:) – Shawn Taylor Jan 4 '18 at 22:01
8

Change the value of useMouseKeysShortcutKeys to NO in 'com.apple.universalaccess.plist'. I believe you will find the files in ~/Library/Preferences/. When you're done, don't forget to reboot ;)

Also, you can do this via Terminal by typing defaults write com.apple.universalaccess useMouseKeysShortcutKeys NO and pressing enter. You may need admin rights to do this.

2

There's indeed an option to disable that permanently

Step 0

Search for "Mouse Keys" in spotlight

Step 1

step1

Step 2

step2

0

To disable mouse keys I went to system preferences

-1

timothy go to accessibility in system preferences and then mouse and track pad then click options and it is the first option

  • 2
    Maybe you can write it as steps rather than one line. – Rob Aug 1 '14 at 6:16
  • "went to the appropriate place in System Preferences to disable this, … but it's greyed out." I no longer have the problem, so it's moot, but your answer doesn't address my question. – Timothy Mueller-Harder Aug 1 '14 at 11:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .