Whenever I start up my old Mac Mini, I get an error indicating that it can't connect to an SMB share that I set up a long time ago:

Non-existent SMB connection error

So that this question is findable via Google, the text of this error message is:

Connection failed

The server "PROSECCO.STUDY.LOCAL" may not exist or is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

I'd like to remove this connection, so that the Mac never tries to connect to the Samba share on the other (long-since expired) computer, but I can't find where to do this. Can anyone tell me how to do this? (The share doesn't appear in the Finder anywhere that I can find, and it's not shown anywhere under System Preferences ... -> Networking -> Advanced...)

(This Mac Mini runs Mac OS X 10.6.8, and is one of the models that isn't upgradeable to Lion.)

6 Answers 6


It depends on how this was set up to launch. From boot, Go > Connect to Server > (click the dropbox) and select clear recent servers, if not using any. Then go to System Preferences > Accounts and see if there is something set up in the Login Items tab related to the server and clear. Restart and test. If it continues I'd check Macintosh HD > Library > LaunchDaemons for a file related to mounting the server.

  • There was nothing listed under "Recent servers" (and no "Clear Recent Servers" option), but under the Login Items tab of System Preferences > Acounts, there was one with "Item" MARK and "Kind" Unknown. I removed this by clicking the - button, and on restarting I no longer get the error! Many thanks for your help. Commented Jul 14, 2012 at 22:57
  • I'm unable to remove it for myself - likely due to a server profile that was added that is no longer enabled. :(
    – cgseller
    Commented Nov 7, 2015 at 21:22
  • 3
    "Accounts" is now "Users and Groups"
    – linuxdan
    Commented Jun 11, 2016 at 17:00

Here's how I solved this problem - the scorched earth method - find all preference files with the server name and remove them.

Replace server_name with the name of the server giving you grief, replace file_name with the name of the preference files you find:

  1. in a terminal:

    cd ~/Library/Preferences/
    sudo grep -R "server_name" .
  2. for each file returned:

    mv file_name ~/Desktop/
  3. restart

  4. rejoice


I had the same problem and could not find out which SMB share the failure was related to. None of the answers worked for me.

I then checked my time machine setup. It was deactivated but I still had two old unused shares in it. I removed them and I guess this solved the problem.

(Originally, I checked the plugin time machine scheduler, because I thought of it as the problem. This led me to time machine itself.)

  • In my case also Time Machine was the problem. After removing my current Time Machine destination the issue was gone. I am also a time machine scheduler user.
    – Pete
    Commented May 7, 2019 at 10:54

A user's SMB configurations can usually be located in:

  • 1
    Thanks for your answer, but I'm afraid that file doesn't exist - in fact, find ~ -iname '*smb*' doesn't find anything... Commented Jul 14, 2012 at 22:52

Go to the finder, keep going up by "cmd + up arrow" till you reach this screen

enter image description here

Now right click and Eject.


For me the problem was that "Enterprise Connect" had stored the shared drive. Going to Enterprise Connect icon --> Shares and deleting the shared drive solved my issue.

I also searched for the shared drive in the Keychain and deleted the credentials that had been stored.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .