My iPhone crashed while it was connected to the computer. I performed synchronization and left the phone so it can recharge. When I looked it after some time I saw Apple logo. I have tried multiple times to reset it (power + home) but every time it just stuck on Apple logo.

After some time I gave up and decided to restore it but even that didn't work. Each time it just stuck on the progress bar. Here are things I have tried:

  • different USB ports
  • different sync. cables
  • different machines (desktop and laptop)
  • windows and mac
  • DFU mode

every time same result.

Bringing iPhone to the Apple store is not an option because I am in a unsupported country without the Apple stores.

enter image description here enter image description here

  • Are you absolutely sure you did the DFU correctly? Had you jailbroken the phone before this point?
    – hellothere
    Jul 20 '12 at 0:53
  • As I know DFU mode is when the screen is black and iTunes recognize it and offers restore. Yes, it was jailbroken but this didn't meter before. Jul 29 '12 at 20:13
  • Sometimes depending on how an iPhone is jailbroken or if the jailbreak has a problem, it can result in corrupted firmware, which in some cases can be unrecoverable.
    – hellothere
    Jul 30 '12 at 0:05
  • @hellothere Any reference on that? I don't agree with that.
    – bot47
    Aug 26 '12 at 19:01
  • 1
    It's not common but I have seen it happen. Might be due to a faulty phone of course.
    – hellothere
    Aug 26 '12 at 21:38

Try RecBoot from sebby.net for Mac (and Windows).

The RecBoot application lets you put your iPhone into and out of recovery mode easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .