I'm not sure what's going on here. I just got this iPad 2, and from the moment I connected it to my wireless network, my other Macs were kicked off, and haven't been able to pull IP addresses from the router.

All my Macs are running Lion. The iPad 2 is running iOS 5.1.1 and has no problems with internet connectivity. I'm using a Motorola Surfboard SBG6580 cable modem with built-in g/n Wi-Fi. That device has been serving me well for over 2yrs, except for the occasional firmware snafu with Comcast. The DHCP service is turned on.


  1. I tried creating reservations for each device on my network, thinking that there was maybe some IP conflict, but that's not the case.
  2. I've tried statically assigning IP's to my Macs as well. Even that doesn't work.
  3. The Airport icon has an exclamation point, and the troubleshooter isn't helping either.
  4. I've restarted all of my devices many times.

Any advice how to fix this situation would be appreciated.

  • What kind of router are you using? Have you tried doing a complete reset of your router (typically with a small button on the device)? Jul 13, 2012 at 20:58
  • My modem is also my router. bit.ly/Mw9YkC So, resetting it to factory default would probably require ISP re-provisioning and make matters worse.
    – protolif
    Jul 31, 2012 at 12:15

1 Answer 1


After testing one router configuration at a time, I finally fixed it. I had to change the wireless access point frequency from 5Ghz to 2.4Ghz. The option is called "802.11 Band" in the web interface. I hope that nobody else has to go through this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .