mds: (Warning) FMW: event:1 had an arg mismatch. ac:2 am:51

This error shows up in my system.log file regularly. Searching on Google turns up few useful results.

One search result points to iTunes plug-ins/add-ons, all of which I have removed with no change; I still get this error.

Since the error is coming from mds I tried resetting Spotlight, but nothing changed. I have also cleared caches, fixed permissions, run maintenance scripts, verified/repaired the file system in Disk Utility, verified Time Machine backups, even did a surface scan of my hard drive. Anything I could think of that might effect the file system and cause trouble for mds.

I'm at a loss. Does anyone have any clue what this means and how I can make it stop?

EDIT: During Spotlight re-indexing (with sudo mdutil -E /), I got a while lot of...

7/20/12 3:27:43.796 PM com.apple.mdworker.pool.1: PSSniffer error: Invalid argument


7/20/12 3:53:19.098 PM com.apple.mdworker.isolation.0: failed to parse embedded CMap.
7/20/12 3:53:19.098 PM com.apple.mdworker.isolation.0: syntax error, unexpected DICTSTART.

...each repeated many times over in short bursts.

The same error I had before also came up during and after re-indexing.

  • Could you be explicit about the steps you took to "reset" spotlight? It's not likely to be a cache/permission/repair issue but nice to know they have been at least looked at.
    – bmike
    Commented Jul 11, 2012 at 18:26
  • If I recall correctly, I just did the ol' add to privacy settings, then remove again this time around.
    – iynque
    Commented Jul 20, 2012 at 18:10
  • Nice - that is very safe and unlikely to cause further issues (which some command line tools and poking at files that contain the data structures can cause)
    – bmike
    Commented Jul 20, 2012 at 18:40

1 Answer 1


These are undocumented internal error conditions and most people outside of Apple can't say for sure what they mean. I wish I had a better, more concrete answer, but here are some ways to poke at your system to get a hint at which file is causing these errors to be emitted...

mds == indexing service. rule of thumb == don't f**k with it unless you know what you do.

  1. Have you reset the spotlight database using any command line tools? (mdutil or mddiagnose) or conventional methods adding/removing directories from the privacy pane in System Preferences?
  2. Does mdutil -s -a -v say anything useful?
  3. Disabling dropbox may help narrowing the cause

Lastly, watching for other mds related console output might be helpful.

  • This is no answer. Please post questions as comments!
    – bot47
    Commented Jul 11, 2012 at 14:50
  • 1
    Starting up and having 0 reputation makes that difficult Max ;-)
    – PJJ
    Commented Jul 11, 2012 at 15:04
  • There's enough good information here to have a partial attempt at answering it. I wish I had the source code and could even tell you what FMW was, but we may get some better information as the question has time to age on the site.
    – bmike
    Commented Jul 11, 2012 at 18:25
  • 1. I used the privacy pane method. I'm trying the command line now. 2. Nothing of interest; looks normal. 3. I frequently disable DropBox and other background apps to free up resources (and then return them when I'm done working). This doesn't seem to have an effect, but I'll keep an eye on it now that you say that.
    – iynque
    Commented Jul 20, 2012 at 18:34
  • ...and I have no idea how to look for problems using mddiagnose. I didn't see anything obvious in the output file.
    – iynque
    Commented Jul 20, 2012 at 18:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .