Every time a backup completes I get this message -

'Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.'

I am backing up to Lacie Network Space 2 drive via wifi.

Does anybody know how to correct this?

  • When did this message start? When you upgraded to Lion, for example?
    – GEdgar
    Commented Jul 11, 2012 at 1:17
  • I can't recall upgrading any software when it first started showing.
    – user20236
    Commented Jul 11, 2012 at 6:20
  • Any fix to this issue?
    – adib
    Commented Nov 8, 2012 at 12:21
  • I am currently seeing this issue running 10.8.2 with a wire connection to my 3TB MyBookLive from WD. Any help is appreciated!
    – tarheel
    Commented Mar 6, 2013 at 5:30

4 Answers 4


There is a very good thread here


On page 4, user Hoppah discovers that his Time Machine (TM) backups go corrupt if they occur simultaneously with "RAID scrubbing." The RAID scrubbing is a function of the network application server (NAS) run periodically to check consistency.

Hoopah used the TimeMachineEditor utility to ensure that TM backups did not occur at the same time as the RAID scrubbing. That solved his problem.

There is a post from a user Christof Birkenmaier, also on page 4, about how to mount the disk image of the backup and delete the portion of the backup causing the problem. It is a very ugly fix that requires editing the TM record of its state. Scary.

A blog entry at


explains loading the TM disk image with the Disk Utility to repair it. If that fails, it explains a command line method to run a file system check on the attached, but not mounted TM disk image.

Elsewhere in the thread first referenced above, from discussions.apple.com, on page 3, there is information about how to look at log files to spot the errors.

It appears TM backups may be corrupted if the network connection is interrupted during backup. You pack up and leave your house while the backup is running. That pulls the plug on your wireless connection to the backup device. Nasty thing to do to TM.

I have decided to run TM manually, when I know it won't get interrupted, and when I know the NAS is not doing RAID scrubbing.

  • 1
    There are reports of this happening with non-RAID NAS, even happening with Apple's own Time Capsule (lookup that discussion thread). Hence RAID scrubbing isn't the sole cause.
    – adib
    Commented Dec 13, 2015 at 6:12

This will not get fixed until Time Machine re-engineer its approach and move away from using a remote-mounted disk image over the network.

The problem lies due to network connections inherently being unreliable (more so wireless networks). However the file system (HFS+) was built for locally-attached disk and assumes that the connection is mostly reliable. Using Time Machine over the network is like writing to a hard drive in which you often unplug the cable mid-transfer. Eventually corruptions occur.

The only way to correct this is to file a bug report to increase the priority of fixing this within Apple's engineering group.

More information here.


I've been having this problem since upgrading to Lion. Perhaps interesting and related, my iMac using a wired network connection does not exhibit this problem while the two MacBook Pro's connected over wireless do have this problem.

I've been able to successfully fix this following these instructions: Fix Time Machine Sparsebundle NAS Based Backup Errors. Unfortunately it'll fix it for a few backups then the problem pops up again and I need to run through the same fix again.


Connect to your external hard drive via USB, Firewire, or Thunderbolt.

Problems can occur when backing up over a network connection that corrupt the time machine backup.

This apple support communities discussion ended menitoning the Airport Extreme Base Station as a possible cause of the problem.

This site goes into more detail about the error message.

Time Machine locks the sparse bundle containing your network backups, and marks it as damaged. You may be able to view and restore some things from these backups, but you will not be able to continue backing-up to them. Disk Utility may appear to repair them, but they’re still damaged and if you try to back up to them again, you’ll just get the same message again.

  • 1
    I would not refer to "Apple Support Communities". They seem to be biased towards "user error", and often reject possibility of bugs in the software or hardware on the premise that this software and hardware is perfect. They are useful as long as the issue is solved by system software, or there is a neat way of clicking, dragging, putting wet phone to rice, using some combination of system software in a non-standard way, but that is it.
    – user68358
    Commented May 9, 2020 at 0:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .