I can't figure out why Finder isn't letting me delete files under my home directory without providing my password. Here's a listing of some files on my desktop:

~/Desktop steve 526$ ls -l@ flower*
-rw-r--r--@ 1 steve  steve  43909 Jun 10 12:01 flower1.png
    com.apple.FinderInfo       32 
    com.apple.quarantine       25 
-rw-r--r--@ 1 steve  steve  57568 Jun 10 12:03 flower2.png
    com.apple.FinderInfo       32 
    com.apple.quarantine       25 
-rw-r--r--@ 1 steve  steve  42322 Jun 10 12:04 flower3.png
    com.apple.FinderInfo       32 
    com.apple.quarantine       25 
-rw-r--r--@ 1 steve  steve  41845 Jun 10 12:04 flower4.png
    com.apple.FinderInfo       32 
    com.apple.quarantine       25 
-rw-r--r--@ 1 steve  steve  37917 Jun 10 11:58 flower5.png
    com.apple.FinderInfo       32 
-rw-r--r--@ 1 steve  steve  73718 Jun 10 11:59 flower6.png
    com.apple.FinderInfo       32 
-rw-r--r--@ 1 steve  steve  62222 Jun 10 11:59 flower7.png
    com.apple.FinderInfo       32 
-rw-r--r--@ 1 steve  steve  51334 Jun 10 12:00 flower8.png
    com.apple.FinderInfo       32 

When I try to delete a file from Finder, I get this:

Finder asking for password

Here's a listing of my home directory. The permissions all look reasonable to me.

~ steve 534$ ls -al@
total 112
drwxr-xr-x@ 34 steve  steve   1156 Apr  7 09:16 .
    net.decimus.synk.fakeVolumeUUID    36 
drwxr-xr-x   8 root   admin    272 Apr  7 09:38 ..
-rw-r--r--   1 steve  steve      3 Jul 18  2006 .CFUserTextEncoding
-rw-r--r--@  1 steve  steve  21508 Jul  1 14:38 .DS_Store
    com.apple.FinderInfo       32 
drwxrwxrwt@  3 steve  steve    102 May 12  2008 .TemporaryItems
    com.apple.FinderInfo       32 
drwx------  34 root   steve   1156 Jul  8 08:40 .Trash
drwxr-xr-x   2 steve  steve     68 Nov 12  2008 .Xcode
-rw-------   1 steve  steve  12721 Jul  4 17:04 .bash_history
-rw-r--r--@  1 steve  steve    464 Jan 17  2008 .bash_profile
    com.apple.FinderInfo       32 
drwx------   3 steve  steve    102 Sep 25  2008 .cups
drwx------  14 steve  steve    476 Jul  8 08:19 .dropbox
-rw-------   1 steve  steve      0 Jan  2  2009 .gdb_history
-rw-------   1 steve  steve     46 Feb  1  2010 .lesshst
drwxr-xr-x   6 steve  steve    204 Jan  9  2010 .lilypond-fonts.cache-2
drwx------   2 steve  steve     68 Jan 17  2008 .macports
drwx------   3 steve  steve    102 Jun 14  2010 .ssh
drwxr-xr-x   6 steve  steve    204 Dec 19  2008 .subversion
-rw-------   1 steve  steve   1661 Dec 19  2008 .viminfo
drwx------  18 steve  steve    612 Jul  8 08:50 Desktop
drwxr-xr-x  18 steve  steve    612 Jul 19  2009 Development
drwx--x--x  13 steve  steve    442 May 28 11:19 Documents
drwx------  43 steve  steve   1462 Jul  6 15:10 Downloads
drwx------@ 20 steve  steve    680 Jul  8 08:19 Dropbox
    com.apple.FinderInfo       32 
drwxr-xr-x  24 steve  steve    816 Jun 10 11:12 EmagicBugReports
drwxr-xr-x   3 steve  steve    102 Feb 15 19:57 FXpansion
drwxr-xr-x@ 55 steve  steve   1870 Jun 29 20:05 Library
    com.apple.FinderInfo       32 
drwx------+ 14 steve  steve    476 Jul  9  2011 Movies
drwxrwxrwx  26 steve  music    884 Feb 11 14:13 Music
drwx------   7 steve  steve    238 Feb 22  2011 Pictures
drwxr-xr-x  13 steve  steve    442 Jul  8 08:49 Prime95
drwxr-xr-x   8 steve  steve    272 Sep 25  2011 Public
drwxr-xr-x   7 steve  steve    238 Feb  2  2008 Sites

I can delete the files from Terminal with rm flower1.png without problem. Why is Finder being so picky?

I already tried repairing permissions in Disk Utility.

Edit Sorry, forgot to mention that I'm running OS X Lion 10.7.4.

  • okay — I thought you might be using Lion, although the datestamps on some of your directories looked pretty old, so I was a bit uncertain.
    – l'L'l
    Commented Jul 8, 2012 at 18:40

3 Answers 3


From what I can tell you've got some funky group permissions. Normally your user membership would belong to the staff group. It appears you have only one directory with an ACL associated with it also (Movies). Usually the other main directories in your home folder such as downloads, desktop, pictures, etc. would have ACLs too. I realize not everyone has their system configured the same, so without knowing more that's all I can tell.

The following command in Terminal should add your username into the staff group:

sudo dscl . -append /Groups/staff GroupMembership `whoami`

It also couldn't hurt to reset your password and ACLs by:

  1. (for 10.7+) Restart then hold R, which should boot into the recovery partition.

  2. (for 10.5+) Insert the OS X Installation DVD and reboot with the C key held down.

  3. Choose language and select "Terminal" from the Utilities menu, then type 'resetpassword' to open the password reset utility.

  4. Select your hard drive and your user account from the drop-down menu.

  5. Click the "Reset" button next to "Reset Home Directory Permissions and ACLs."

  6. Select "Restart" from the Apple menu and then see if the issue is gone.

If you still have trouble try the following:



dscl . -read /Groups/steve GroupMembership


ls -le@a

and post the results back here.

  • Excellent answer. I had not heard of the resetpassword utility. That did the trick. The standard directories in my user directory now all have an ACL containing "group:everyone deny delete". My files are all assigned to the group "staff" although when I changed one back to "steve" I was able to delete it. So the issue must have been more than just the group. But it works and that's all that matters. Thanks!
    – SSteve
    Commented Jul 8, 2012 at 18:55
  • I'm glad it resolved your issues; the utilities on the recovery partition definitely come in handy when something might need to be reset (i.e. keychain). The reason for being able to change the group to steve and then delete it without problems is because you're now in the staff group. Before you where in the steve group, which didn't have the privileges that you have now. You can always check the privileges of usernames/groups using the last three commands above. ;-)
    – l'L'l
    Commented Jul 8, 2012 at 21:31
  • I've tried these things and am still having this problem. When I run the dscl command I get DS error: -14136 (eDSRecordNotFound). When I run the ls it shows my username and staff for everything except 1 that has root and admin. I also get the everyone deny delete like Steve mentioned. Any ideas on what to do next?
    – WendiKidd
    Commented Apr 19, 2014 at 1:32
  • I found this, but when I navigate to that section, "Apply to enclosed items" is grayed out.
    – WendiKidd
    Commented Apr 19, 2014 at 1:35
  • @WendiKidd, The error you describe is related to the Open Directory daemon. What is the exact command you used?
    – l'L'l
    Commented May 3, 2014 at 22:34

OS X asks for a password whenever you try to delete a file because your ~/.Trash folder belongs to the root user and has permissions drwx------ — noone but root can read, write or open this folder. Being in the same situation I tried the command shown below in Terminal and it helped:

sudo chown -R steve:staff ~/.Trash

Note that I've changed my username to yours in this example. Also note that sudo command will ask you for user password — it's OK.


This might likely be a permission issue. Maybe you can check some files in your folder for permission using the terminal.

Simply navigate into your target folder and type ls -l

Then take a look at the left column:

enter image description here

The leading d tells you if it is a directory. Then you have 3 chunks consisting of 3 letters each. The first chunk is for the user, the second for group and the rest for other. And r = read, w = write, x = execute.

Something like rwx-xr-x would mean that user has all rights, group can only read and execute (not write), and other can only execute.

To be on the save side, you could set everything in this folder to rwxrwxrwx by typing chmod ugo+rwx * -R into the terminal. u for user, g for group, and o for other. And via the + you'll give all three of them all permissions. The asterisk is the wild card that stands for everything that is in this folder, and the -R (recursive) makes sure, that you also cover the subfolders.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .