1

Somehow my harddrive seems to fail, I am not able to startup anymore. When I started in verbose mode, I noticed that the harddrive return I/O Errors and the B-Node-Tree seems to be corrupted.

I was able to use the single-user mode to backup files to an external harddrive, but when I tried to repartition the harddrive from the recovery mode, after failing to repair the partitions in single-user mode, I get an error, that he is unable to unmount the drive.

(DiskWarrior 4.4 doesn't even recognize the Macintosh HD and the S.M.A.R.T Test results are alright)

I first thought maybe something is actually used on that drive, but even after trying to repartition from the Disk Utility on a Mac OSX Lion Installer DVD, he keeps telling me, that he is unable to unmount the drive.

(I had a bootcamp partition on the harddrive as well, that is still highlighted, so that seems to be the issue)

The system is an early 2011 MBP.

6

Open Terminal and try entering following:

df

which will give a listing of your mounted volumes similar to:

Filesystem    512-blocks       Used  Available Capacity  Mounted on
/dev/disk0s2  1951845952 1655141456  296192496    85%    /
devfs                477        477          0   100%    /dev
map -hosts             0          0          0   100%    /net
map auto_home          0          0          0   100%    /home
/dev/disk1s2  1952853344  754604936 1198248408    39%    /Volumes/Backup

depending on which drive you need to unmount you can then try:

sudo hdiutil eject -force /dev/disk1s2

which would force /Volumes/Backup to be unmounted.

  • 1
    This "hdiutil eject -force <mounted drive name>" worked like charm. I had mounted SSHFS, tried to umount it, but somehow encountered error. I even tried to kill the process, but still the error persisted. However, hdiutil did the task. thanks – ravi.zombie Oct 19 '15 at 18:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .