I've read many posts here and on other forums about installing Windows 7 from a USB stick, and I really don't want to start messing about with the VM Ware Fusion or Parallels options. Last resort will be sourcing an external superdrive, but I thought I'd ask if there's an updated way to achieve this.

I'm running a 15" MBP early 2011 and have a 256gb SSD in the main drive bay, and a 500gb HDD in the optical drive bay.

I've edited Bootcamp's info.plist to enable it to create a bootable USB stick with the Windows installer and drivers on, but upon reboot, it comes up with the missing operating system error.

I've also tried creating a USB stick within Windows with Microsoft's own tool, and used rEFIt to try and boot with the same problem.

And finally I tried booting with a USB Freecom DVD drive and the original Windows 7 DVD, but that ends up just flashing a _ on a black screen.

Are my only options really either using an Apple external superdrive, or a lot of messing about with VMware Fusion and reimaging with a cloning tool?

  • Have you tried this?
    – Thecafremo
    Commented Jul 6, 2012 at 8:21
  • In the end the the only way I could get this to work is to reinstall the superdrive and install it on the main drive. I hoped to winclone it to the second drive after putting the ssd back in, but I couldn't get that to boot successfully. Seems to be pretty hit and miss if you go against the standard config which Apple expects people to use, but at least it works now.
    – AlanJC
    Commented Jul 29, 2012 at 22:37
  • use refit to boot rather than using bootcamp.
    – user28705
    Commented Sep 7, 2012 at 2:37
  • I'd said in the original post that I'd tried rEFIt with no joy. It's working now as I'd reinstalled the superdrive to do it, but no matter what I tried it just wouldn't boot. I've seen similar reports elsewhere but no consistency in why it works for some and not others.
    – AlanJC
    Commented Sep 7, 2012 at 10:04
  • Here is the refit report anyway. Not sure if it will show why the bootable USB has stopped working. *** Report for internal hard disk *** Current GPT partition table: # Start LBA End LBA Type 1 40 409639 EFI System (FAT) 2 409640 123513703 Mac OS X HFS+ 3 123775848 125045383 Mac OS X Boot Current MBR partition table: # A Start LBA End LBA Type 1 1 409639 ee EFI Protective 2 * 409640 123513703 af Mac OS X HFS+ 3 123775848 125045383 ab Mac OS X Boot MBR contents: Boot Code: Unknown, but bootable Partition at LBA 40: Boot Code: None (Non-system disk message) File System: FAT32 Listed in GPT as pa
    – user31754
    Commented Oct 12, 2012 at 15:59

3 Answers 3


Having exactly the same problem. It took a long time, and a lot of trail/error/forum reading to get to where you did (editing info.plist). I removed my 'useless' superdrive also.

Refit has a utility to rebuld partition info as Mac likes it (after using gparted, in my case to grow the bootcamp partition as I made it too small), but after that nothing wants to boot into my windows boot usb key to run the final step which is the repair of the windows install/boot config.

Maybe osx adds some boot info immediately after you commence creating the bootcamp environment with Boot Camp Assistant. I remember it always booted into windows until you finish setting windows up... either by 'Option' selecting OSX on boot, then rebooting from system prefs, boot disk page. Or rebooting from Windows bootcamp tools. This worked also into windows setup if your USB was in. Once you have done that though, nothing wants to boot off your Windows install USB. Not even refit.

Unfortunately for me, that's where the windows repair utility lives which will complete the fix of my partition resize.

Obviously recreating the bootcamp partition would do it. But that defeats the purpose of trying to grow it without reinstalling windows in the first place.

Bloody hell, I already had to open my MBP up as the windows installer likes to fail if you have a HD attached to your Super Drive Sata port.

Might have to wipe, disconnect OSX and reinstall windows all over. Paragon Boot Tune is supposed to be able to resize Boot camp, but the damn thing requires a superdrive to burn a boot disc to!

Only other thing I can think of is that refit ruined something. But I don't think so. FYI I also removed refit and can select the Win Boot Camp partition or Boot USB Key but they fail that way also.

Anyone reading this... make sure your Bootcamp partition/drive is at least 30gb. Windows takes 15-25 (if you include room to move for temp files, caches and updates etc. Then you got apps on top of that.

  • Mark, it's kind of hard to find the answer in the text. Can you summarize the answer part in a new first paragraph and leave the rest as reference?
    – nohillside
    Commented Oct 14, 2012 at 12:48

Bootcamp will create a Windows partition from a

a USB flash drive that contains a Windows 7 ISO image downloaded from Microsoft. Boot Camp Assistant helps you burn the image to the flash drive.

See the Lion Bootcamp install notes from Apple - similar notes exist for Snow Leopard.

I have installed the Windows 8 RC using this method.

  • Maybe I didn't state it clearly enough, but I've tried that. The ability to create the flash drive from an ISO is only native to MacBook Airs and the Retina MacBook Pro, so by editing the info.plist to enable this feature I was able to create it, but something else is missing to enable it to boot correctly from it.
    – AlanJC
    Commented Jul 6, 2012 at 7:08

I just bought a USB housing for my optical drive, and then I found this thread... But I did find something that might help anyone needing to install Windows without an optical drive. About to try this myself. http://www.andrewsavory.com/blog/2011/2156

  • 1
    Hi, can you share what you did find out about this link? Giving context to your links is highly appreciated.
    – myhd
    Commented Oct 13, 2012 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .