Sometime last week my dock stopped showing up. I rebooted and the problem persists. I can get it back if I go to dock preferences and disable autohide, but I like to keep my screen real estate and would like to have the autohide working.

Anybody have any suggestions on how to fix this?


Go to System Preferences > Dock and then turn On and then Off the Automatically hide and show the Dock. That will reset the dock.


Try setting the dock (with auto-hide) to the left or right side of the screen. If either of those work, it would seem that you may have a screen resolution setting that's keeping the dock off-screen.

Perhaps try changing your resolution, or bouncing it from one to another.

If none of that helps, you can try deleting the dock preferences (returning it to its default state) and restarting the dock.app

  • Navigate to (or just spotlight to): ~/Library/Preferences
  • Delete (or just move them to your desktop) com.apple.dock.plist and com.apple.dock.db
  • Open up the terminal and enter the command: killall Dock (if you don't like terminal and killing, you could log out and in again as well)

This will force the dock to make new preference files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .