The headphone jack on my MacBook Pro stopped working. It was working fine, then just spontaneously stopped while I was using external speakers plugged into the output jack. Now, neither speakers nor 3 different headphones have sound. The internal speaker on my MacBook Pro still works.

  • 2
    What other steps have you taken to try and get it working again? What OS? Have you tried restarting? Have you checked settings under System Preferences -> Sound? – ephsmith Jul 1 '12 at 17:26
  • Did the sound stop working while the external speakers were still plugged on or afterwards (i.e. when you plugged in the headphones)? In the second case there may be some lint in the jack. – nohillside Jul 1 '12 at 18:01
  • Were you using the computer at the time it stopped working? If so, what were you doing? What operating system version are you running? What is the volume set for when speakers are plugged in? – Daniel Jul 1 '12 at 18:21
  • Shari USA, welcome to Ask Different! Please answer these additional questions and give us some more information, and we will be glad to help you. – user9290 Jul 1 '12 at 20:40
  • 1
    Which model MacBook Pro do you have? Some of them have combination audio ports that can switch to optical audio. If optical audio is erroneously engaged, then your headphones (or any other non-optical hardware) won't work. You can switch it back if this is the case. – iynque Jul 2 '12 at 4:22

This happened to me yesterday. I tried three different headphones.

  1. Go to System Preferences > Sound > Output.
  2. Plug your headphones in if you haven't yet.
  3. Look at the bottom where it says Output Volume and un-check the mute button.
  • Great! It fixed my issue. But how this MUTE checkbox was checked automatically. – Rakesh Juyal Aug 10 '13 at 22:54
  • In my case mute button was not check, but once I got into this menu, headphones started working again. Thanks! – Ivan Virabyan Jan 16 '16 at 10:48
  • What worked for me: mute headphones, then unmute them. Nothing else worked except this. Thanks Panusiri – xaphod Mar 16 at 14:40

I had this same problem with my MacBook Pro 13" (mid-2009) running OS 10.6.8. Somewhere on the internet I found the answer. After plugging in the headphones and looking at the System Preferences/Sound, you may not see (in theis model) the option for Headphones, only for Internal Speaker. (Of course, you must first check that the audio port is selected for output, since this Mac has only a single port audio. Also, that the mute is not selected.) After seeing no Headphone option, put the Mac to sleep and wake it up again. Voila! Your headphones/external speakers will work.

Does anyone know what the permanent fix is for this problem?

  • This worked for me. Very strange issue. Mac OSX 10+ (Mac Book Pro Mid-2012) – Jared Burrows Jan 25 '15 at 0:14
  • Fixed it also for Mac OS X Yosemite on MacBook Pro Late 2013. I guess something get's reinitialized after waking up. But having it not fixed for over two and a half years... – PVitt Feb 11 '15 at 12:59
  • I just had to do this again. – Jared Burrows Apr 19 '15 at 16:56

If you see red glowing light coming from it try the toothpick approach: take a toothpick and poke around in the jack until light turns off.

  • 2
    I have had this in the past, and this method fixed it – markhunte Oct 15 '12 at 21:49
  • I never thought this trick would work lol – lomse Mar 7 '15 at 23:30
  • Just optical/analog mode ball switch gets clogged. Kind of they did in old ball mouse – iskra Mar 30 '15 at 14:19

I've had similar issues and restarting coreaudio work for me. Run this in a terminal (you might be prompted for your password).

sudo pkill coreaudiod

If your curious sudo is something used to run commands as administrator (SU-DO as in super user do) and pkill sends signals to processes based on name in this case coreaudiod which is the name of the coreaudio service process. When it gets the signal (SIGTERM in this case) it will terminate and then OSX will start it again.

  • 1
    worked for me when system preferences and sleep didn't – Noam Hacker Oct 2 at 19:09
  • @NoamHacker Nice! Some years ago i used to have to do this all the time... now a lot less. Strange. – Mattias Wadman Oct 3 at 11:17

Try resetting PRAM.

Restart your machine and hold down Command ⌘+Option ⌥+P+R all at the same time as soon as it turns on. Keep holding until it resets.

  • But was it simply the restart which kicked OSX into action? – GlennG Dec 7 '13 at 11:56

Let me tell how I solved my problem (that was: internal speakers worked whereas the headphones plugged in didn't):

  1. I plugged in the headphones.

  2. I pressed the "F10/Sound OnOff" key on the keyboard

That was it! The headphones worked again.

But why? To my understanding the reason is that Apple attaches the sound-on-or-off-state to the current output device.

So switching off the sound while having plugged in the headphones makes the headphones be silent. Plug them off and you will hear the internal speakers. Plug them in again (after a minute or after half a year) and they still will be silent. Because YOU switched off the sound OF THE HEADPHONES (some months ago).

(It is the same the other way round. But in that case you probably would try the F10 button ...)

(Note: you can see this behaviour also with the checked or unchecked mute button in System Preferences > Sound > Output, as mentioned in a post above. Its state depends on the selected output device.)

  • The F10 trick saved me :) I almost freaked out. – Mlungisi Mar 11 '13 at 16:39
  • Wow-I never knew this until now-I freaked out at a DJ gig and was screwed because my headphone jack didn't work! This was why! – Joel Jun 22 '13 at 3:23
  • Thanks for this: "Apple attaches the sound-on-or-off-state to the current output device." ! – mujimu Feb 11 '15 at 19:00

I'm not sure if it's a hardware issue for you; if you go under System PreferencesSoundOutput, you should see Headphones as one of the output devices. Most likely the audio is being directed to some other output device (like Soundflower or Boom). Just make sure that Headphones is selected.

In the sounds control panel with the sound output tab selected, be sure to have use audio port for output, rather than input... this was why mine was not working.

protected by nohillside May 2 '15 at 19:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.